Opened 5 years ago

Closed 5 years ago

#603 closed enhancement (needs_more_info)

FFmpeg can't display file information

Reported by: zexon Owned by: michael
Priority: normal Component: ffmpeg
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no


Why FFmpeg cannot show / export file information?

It's ridiculous to use a separate program called FFprobe just to get a few lines of file information. FFprobe is equally as big as FFmpeg, adding another 16 MB to the total size.

FFmpeg retrieves file information anyway, since it needs it to perform the conversion. It could show just the basic info, like file format, number of frames, frame rate, image size, audio format, etc, that can be redirected to a file. Like this:

ffmpeg -info file.mpg > file_info.txt

I'm sure I'm not the only one that wants this.

Change History (2)

comment:1 Changed 5 years ago by cehoyos

  • Keywords file info information display removed

What's wrong with

ffmpeg -i file.mpg >file_info.txt


Version 0, edited 5 years ago by cehoyos (next)

comment:2 Changed 5 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

Please reopen if more information can be provided.

Note: See TracTickets for help on using tickets.