Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#584 closed defect (fixed)

WTV MUX generates malformed files

Reported by: ianken Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: wtv
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

re-muxing from one WTV file to another results in unplayable WTV file...

d:\Convert\BIN\FFMPEG32\bin>ffmpeg -threads 6 -i "test2.wtv" -sn -vcodec copy -acodec copy "test.wtv"
ffmpeg version N-33818-gd049257, Copyright (c) 2000-2011 the FFmpeg developers

built on Oct 19 2011 22:57:39 with gcc 4.6.1
configuration: --enable-gpl --enable-version3 --enable-runtime-cpudetect --ena

ble-avisynth --enable-bzlib --enable-frei0r --enable-libopencore-amrnb --enable-
libopencore-amrwb --enable-libfreetype --enable-libgsm --enable-libmp3lame --ena
ble-libopenjpeg --enable-librtmp --enable-libschroedinger --enable-libspeex --en
able-libtheora --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis
--enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib

libavutil 51. 22. 0 / 51. 22. 0
libavcodec 53. 22. 0 / 53. 22. 0
libavformat 53. 17. 0 / 53. 17. 0
libavdevice 53. 4. 0 / 53. 4. 0
libavfilter 2. 44. 1 / 2. 44. 1
libswscale 2. 1. 0 / 2. 1. 0
libpostproc 51. 2. 0 / 51. 2. 0

[wtv @ 01B889C0] unsupported chunk:f71002b9ee7ced4ebd7f0540358618a1
[wtv @ 01B889C0] parser not found for codec dvb_teletext, packets or times may b
e invalid.
[mpeg2video @ 01A97180] mpeg_decode_postinit() failure

Last message repeated 12 times

Seems stream 2 codec frame rate differs from container frame rate: 119.88 (12000
0/1001) -> 59.17 (355/6)
Input #0, wtv, from 'test2.wtv':

Metadata:

WM/MediaClassPrimaryID: db9830bd-3ab3-4fab-8a371a995f7ff74b
WM/MediaClassSecondaryID: ba7f258a-62f7-47a9-b21f4651c42a000e
Title : Dinosaur Big City
WM/SubTitleDescription: Buddy and his family go to the city for the Theropod

Club Convention.

genre : Special;Other
WM/OriginalReleaseTime: 0
WM/MediaCredits : ;;;
service_provider: KCTSDT
service_name : KCTSDT (KCTS-DT)
WM/MediaNetworkAffiliation: PBS Affiliate
WM/MediaOriginalChannel: 509
WM/MediaOriginalChannelSubNumber: 0
WM/MediaOriginalBroadcastDateTime: 0001-01-01T00:00:00Z
WM/MediaOriginalRunTime: 38967188000
WM/MediaIsStereo: true
WM/MediaIsRepeat: false
WM/MediaIsLive : false
WM/MediaIsTape : false
WM/MediaIsDelay : false
WM/MediaIsSubtitled: false
WM/MediaIsMovie : false
WM/MediaIsPremiere: false
WM/MediaIsFinale: false
WM/MediaIsSAP : true
WM/MediaIsSport : false
WM/ParentalRating: TV-Y
WM/Provider : MediaCenterDefault?
WM/VideoClosedCaptioning: true
WM/WMRVEncodeTime: 2011-08-27 14:58:03
WM/WMRVSeriesUID: GenericSeries!Dinosaur Big City
WM/WMRVServiceID: !MCService!28458100
WM/WMRVProgramID: !MCProgram!262554684
WM/WMRVRequestID: 0
WM/WMRVScheduleItemID: 0
WM/WMRVQuality : 0
WM/WMRVOriginalSoftPrePadding: 420
WM/WMRVOriginalSoftPostPadding: 180
WM/WMRVHardPrePadding: -300
WM/WMRVHardPostPadding: 0
WM/WMRVATSCContent: true
WM/WMRVDTVContent: true
WM/WMRVHDContent: true
WM/MediaThumbWidth: 352
WM/MediaThumbHeight: 198
WM/MediaThumbStride: 1056
WM/MediaThumbRet: 0
WM/MediaThumbRatingSystem: 9
WM/MediaThumbRatingLevel: 2
WM/MediaThumbRatingAttributes: 0
WM/MediaThumbAspectRatioX: 16
WM/MediaThumbAspectRatioY: 9
WM/MediaThumbTimeStamp: 4646639520060800336
WM/MediaThumbType: 3
Duration : 38991400000
WM/WMRVEndTime : 2011-08-27 16:03:02
WM/WMRVBitrate : 11.647139
WM/WMRVKeepUntil: -1
WM/WMRVActualSoftPrePadding: 416
WM/WMRVActualSoftPostPadding: 182
WM/WMRVContentProtected: false
WM/WMRVContentProtectedPercent: 0
WM/WMRVExpirationSpan: 9223372036854775807
WM/WMRVInBandRatingSystem: 255
WM/WMRVInBandRatingLevel: 255
WM/WMRVInBandRatingAttributes: 0
WM/WMRVWatched : true

Duration: 01:04:47.33, start: 12.485306, bitrate: 11682 kb/s

Stream #0:0[0x26]: Audio: ac3, 48000 Hz, 5.1(side), s16, 384 kb/s
Stream #0:1[0x27]: Audio: ac3, 48000 Hz, stereo, s16, 192 kb/s
Stream #0:2[0x28]: Video: mpeg2video (Main), yuv420p, 1280x720 [SAR 1:1 DAR

16:9], 19392 kb/s, 133.20 fps, 59.17 tbr, 10000k tbn, 119.88 tbc

Stream #0:3[0x29]: Subtitle: dvb_teletext
Stream #0:4[0x0]: Attachment: mjpeg
Metadata:

title : TV Thumbnail

File 'test.wtv' already exists. Overwrite ? [y/N] y
Output #0, wtv, to 'test.wtv':

Metadata:

WM/MediaClassPrimaryID: db9830bd-3ab3-4fab-8a371a995f7ff74b
WM/MediaClassSecondaryID: ba7f258a-62f7-47a9-b21f4651c42a000e
Title : Dinosaur Big City
WM/SubTitleDescription: Buddy and his family go to the city for the Theropod

Club Convention.

genre : Special;Other
WM/OriginalReleaseTime: 0
WM/MediaCredits : ;;;
service_provider: KCTSDT
service_name : KCTSDT (KCTS-DT)
WM/MediaNetworkAffiliation: PBS Affiliate
WM/MediaOriginalChannel: 509
WM/MediaOriginalChannelSubNumber: 0
WM/MediaOriginalBroadcastDateTime: 0001-01-01T00:00:00Z
WM/MediaOriginalRunTime: 38967188000
WM/MediaIsStereo: true
WM/MediaIsRepeat: false
WM/MediaIsLive : false
WM/MediaIsTape : false
WM/MediaIsDelay : false
WM/MediaIsSubtitled: false
WM/MediaIsMovie : false
WM/MediaIsPremiere: false
WM/MediaIsFinale: false
WM/MediaIsSAP : true
WM/MediaIsSport : false
WM/ParentalRating: TV-Y
WM/Provider : MediaCenterDefault?
WM/VideoClosedCaptioning: true
WM/WMRVEncodeTime: 2011-08-27 14:58:03
WM/WMRVSeriesUID: GenericSeries!Dinosaur Big City
WM/WMRVServiceID: !MCService!28458100
WM/WMRVProgramID: !MCProgram!262554684
WM/WMRVRequestID: 0
WM/WMRVScheduleItemID: 0
WM/WMRVQuality : 0
WM/WMRVOriginalSoftPrePadding: 420
WM/WMRVOriginalSoftPostPadding: 180
WM/WMRVHardPrePadding: -300
WM/WMRVHardPostPadding: 0
WM/WMRVATSCContent: true
WM/WMRVDTVContent: true
WM/WMRVHDContent: true
WM/MediaThumbWidth: 352
WM/MediaThumbHeight: 198
WM/MediaThumbStride: 1056
WM/MediaThumbRet: 0
WM/MediaThumbRatingSystem: 9
WM/MediaThumbRatingLevel: 2
WM/MediaThumbRatingAttributes: 0
WM/MediaThumbAspectRatioX: 16
WM/MediaThumbAspectRatioY: 9
WM/MediaThumbTimeStamp: 4646639520060800336
WM/MediaThumbType: 3
Duration : 38991400000
WM/WMRVEndTime : 2011-08-27 16:03:02
WM/WMRVBitrate : 11.647139
WM/WMRVKeepUntil: -1
WM/WMRVActualSoftPrePadding: 416
WM/WMRVActualSoftPostPadding: 182
WM/WMRVContentProtected: false
WM/WMRVContentProtectedPercent: 0
WM/WMRVExpirationSpan: 9223372036854775807
WM/WMRVInBandRatingSystem: 255
WM/WMRVInBandRatingLevel: 255
WM/WMRVInBandRatingAttributes: 0
WM/WMRVWatched : true
encoder : Lavf53.17.0
Stream #0:0: Video: mpeg2video (mpg2 / 0x3267706D), yuv420p, 1280x720 [SAR 1

:1 DAR 16:9], q=2-31, 19392 kb/s, 10000k tbn, 59.94 tbc

Stream #0:1: Audio: ac3 ([0] [0][0] / 0x2000), 48000 Hz, 5.1(side), 384 kb/s

Stream mapping:

Stream #0.2 -> #0.0 (copy)
Stream #0.0 -> #0.1 (copy)

Press [q] to stop, ? for help
frame= 9114 fps= 0 q=-1.0 size= 207411kB time=00:02:32.16 bitrate=11166.6kbits
frame=19052 fps=19051 q=-1.0 size= 431091kB time=00:05:17.92 bitrate=11108.1kbi
...delete...
frame=232981 fps=8760 q=-1.0 Lsize= 5380214kB time=01:04:46.97 bitrate=11339.1kbits/s
video:5155325kB audio:182202kB global headers:0kB muxing overhead 0.799760%

Change History (12)

comment:1 follow-up: Changed 5 years ago by cehoyos

  • Keywords mux removed
  • Version changed from unspecified to git-master

Do the following work?
ffmpeg -i test2.wtv -sn -qscale 5 out1.wtv
ffmpeg -i test2.wtv -sn -vcodec copy out2.wtv
ffmpeg -i test2.wtv -sn -qscale 5 -acodec ac3 -ab 256k out3.wtv

And for those outX.wtv that work, please try:
ffmpeg -i outX.wtv -vcodec copy -acodec copy out.wtv

comment:2 in reply to: ↑ 1 Changed 5 years ago by cehoyos

Replying to cehoyos:

Do the following work?
ffmpeg -i test2.wtv -sn -qscale 5 out1.wtv
ffmpeg -i test2.wtv -sn -vcodec copy out2.wtv

This should be:
ffmpeg -i test2.wtv -sn -ac 2 -qscale 5 out1.wtv
ffmpeg -i test2.wtv -sn -ac 2 -vcodec copy out2.wtv

comment:3 Changed 5 years ago by ianken

I ran all three conversions as directed. Each resulted in a file that would not render in MPC-HC, WMP, Media Center or Graphedt.

If needed I can provide some sample content...

Version 0, edited 5 years ago by ianken (next)

comment:4 Changed 5 years ago by cehoyos

Please provide a sample.

comment:5 Changed 5 years ago by ianken

http://www.funkbasealpha.DOTCOM/Video/test1.wtv

Edit: I've pulled this file from my site...Please ping me if it is needed again.

Last edited 5 years ago by ianken (previous) (diff)

comment:6 Changed 5 years ago by pross

Okay, i can reproduce the error. Looking into it

comment:7 Changed 5 years ago by cehoyos

I tested the following commands with the sample you provided:

ffmpeg -i test1.wtv -sn -ac 2 -qscale 5 out1.wtv
ffmpeg -i test1.wtv -sn -ac 2 -vcodec copy out2.wtv
ffmpeg -i test1.wtv -sn -qscale 5 -acodec ac3 -ab 256k out3.wtv
ffmpeg -i test1.wtv -sn -vcodec copy -acodec copy test.wtv

All four files play fine with WMP12.

Seeking with WMP12 is not possible in all resulting files, is that what you wanted to report?

comment:8 Changed 5 years ago by ianken

"Seeking with WMP12 is not possible in all resulting files, is that what you wanted to report?"

No. With the build I was using I get unplayable files. It looks like Peter got a repro...

comment:9 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from new to closed

It appears this was fixed since you originally opened the ticket (but before I was able to test).

comment:10 Changed 5 years ago by ianken

I've verified that I can now convert from WTV->WTV and that (as noted above) seeking is totally borked.

Seeking it broken not just in WMP, but in MC as well. The SBE source is somewhat confused.

comment:11 follow-up: Changed 5 years ago by ianken

One more thing: I have another test file that fails to re-mux. However it's a 5GB HD recording. SO things are improved, but not fully fixed.

comment:12 in reply to: ↑ 11 Changed 5 years ago by cehoyos

Replying to ianken:

One more thing: I have another test file that fails to re-mux. However it's a 5GB HD recording.

Command line and complete, uncut console output missing.

Note: See TracTickets for help on using tickets.