Opened 3 years ago

Closed 2 years ago

#5840 closed enhancement (fixed)

6-channel atrac3

Reported by: zhidd Owned by:
Priority: wish Component: avcodec
Version: git-master Keywords: atrac3
Cc: bnnm Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description (last modified by cehoyos)

E:\ffmpeg-win32-static\bin
>ffmpeg -i "E:\PKG\NPUB90183\USRDIR\data\audio\music\01 track 1b old.at3"
ffmpeg version N-81516-gbe07c25 Copyright (c) 2000-2016 the FFmpeg developers
  built with gcc 5.4.0 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-dxva2 --enable-libmfx --enable-nvenc --enable-avisynth --enable-bzlib --enable-libebur128 --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libfreetype --enable-libgme --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenh264 --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-libzimg --enable-lzma --enable-decklink --enable-zlib
  libavutil      55. 29.100 / 55. 29.100
  libavcodec     57. 54.101 / 57. 54.101
  libavformat    57. 48.101 / 57. 48.101
  libavdevice    57.  0.102 / 57.  0.102
  libavfilter     6. 58.100 /  6. 58.100
  libswscale      4.  1.100 /  4.  1.100
  libswresample   2.  1.100 /  2.  1.100
  libpostproc    54.  0.100 / 54.  0.100
[atrac3 @ 058a00c0] Channel configuration error!
[wav @ 03757820] Failed to open codec in av_find_stream_info
[atrac3 @ 058a00c0] Channel configuration error!
Guessed Channel Layout for Input Stream #0.0 : 5.1
Input #0, wav, from 'E:\PKG\NPUB90183\USRDIR\data\audio\music\01 track 1b old.at3':
  Duration: 00:06:39.37, bitrate: 29 kb/s
    Stream #0:0: Audio: atrac3 (p[2][0][0] / 0x0270), 48000 Hz, 6 channels, 104 kb/s
At least one output file must be specified

Attachments (4)

01 track 1b old.at3 (1.4 MB) - added by zhidd 3 years ago.
6-channel at3 file
spare_5_1.msf (207.1 KB) - added by bnnm 2 years ago.
spare.msf (67.2 KB) - added by bnnm 2 years ago.
01 track 1b old_new.at3 (1.4 MB) - added by cehoyos 2 years ago.

Change History (9)

Changed 3 years ago by zhidd

6-channel at3 file

comment:1 Changed 3 years ago by zhidd

  • Summary changed from 6-channel at3/msf type to 6-channel at3 type

comment:2 Changed 3 years ago by cehoyos

  • Component changed from ffmpeg to avcodec
  • Description modified (diff)
  • Keywords atrac3 added
  • Priority changed from normal to wish
  • Reproduced by developer set
  • Status changed from new to open
  • Summary changed from 6-channel at3 type to 6-channel atrac3
  • Type changed from defect to enhancement
  • Version changed from unspecified to git-master

Changed 2 years ago by bnnm

Changed 2 years ago by bnnm

comment:3 follow-up: Changed 2 years ago by bnnm

The uploaded sample was manually and incorrectly converted from the original MSF source, so I added a couple of proper examples.

The files use regular, non joint-stereo ATRAC3. For those there is no difference between 1 or N channels, since the channels are discrete.

I'll try to submit a patch which removes the 2ch restriction. I don't know the channel layout though, it's not specified in the .MSF.
Joint-stereo files they'll still fail with >2ch, but I haven't seen any myself.

Changed 2 years ago by cehoyos

comment:4 in reply to: ↑ 3 Changed 2 years ago by cehoyos

  • Cc bnnm added

Replying to bnnm:

The uploaded sample was manually and incorrectly converted from the original MSF source

Can you confirm that the originally uploaded at3 sample is unplayable, no matter which player is used?

I uploaded a fixed at3 file.

comment:5 Changed 2 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.