#5806 closed defect (wontfix)

Major Brand & Minor Version

Reported by: richardbushell Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: mov
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

We are getting conformance messages downstream after ffmpeg based on ffmpeg writing a spec prohibited value for Major Brand in MP4 files.

'isom' cannot be used as a major brand in MP4, it is currently prohibited by ISO/IEC 14496-12 sec 6.3 paragraph 2.

Also, it would be fantastic if you would extend the -brand option to include an option to override the minor version (as well as the major brand), like with the GPAC MP4Box option:
-brand ABCD[:v] sets major brand of file, with optional version

Please advise, thanks.

Change History (1)

comment:1 in reply to: ↑ description Changed 17 months ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords mov added
  • Resolution set to wontfix
  • Status changed from new to closed
  • Version changed from unspecified to git-master

Replying to richardbushell:

'isom' cannot be used as a major brand in MP4, it is currently prohibited by ISO/IEC 14496-12 sec 6.3 paragraph 2.

Do you know of a player that refuses the files? Because changing the major brand to mp41 will most likely brake some (broken) player, I don't think this is a good idea given we allow users to select the major brand anyway.

If you disagree, please send the (trivial) patch made with git format-patch to the development mailing list, this is not the right place to discuss likely controversial patches.

Please report only one issue per ticket.

Note: See TracTickets for help on using tickets.