Opened 2 years ago

Closed 2 years ago

#5739 closed defect (needs_more_info)

Invalid RTCP SR package sent by ffmpeg

Reported by: sancane Owned by:
Priority: important Component: undetermined
Version: unspecified Keywords: rtp regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
ffmpeg is sending an invalid RTCP SR packet, we detected that with the version 2.8.6 of ffmpeg, the RTCP SR sent by ffmpeg does not increment the ntptime, as we could expect so the clock is supposed to be monotonic, This makes it impossible to use RTCP SRs to synchronize. It seems to be a regression from any commit introduced from version 2.7.2 wich were doing it well.

Next is the information about SR sent with ffmpeg 2.8.6:

0:00:41.314525104 Received RTCP SR packet SSRC: 535359325, rtptime: 3030375347, ntptime: 9223372036854775808, ntpnstime: 596523:14:08.000000000
0:00:46.323753635 Received RTCP SR packet SSRC: 535359325, rtptime: 3030826067, ntptime: 9223372036854775808, ntpnstime: 596523:14:08.000000000
0:00:51.355472637 Received RTCP SR packet SSRC: 535359325, rtptime: 3031278947, ntptime: 9223372036854775808, ntpnstime: 596523:14:08.000000000
0:00:56.391561089 Received RTCP SR packet SSRC: 535359325, rtptime: 3031732097, ntptime: 9223372036854775808, ntpnstime: 596523:14:08.000000000
0:01:01.422186827 Received RTCP SR packet SSRC: 535359325, rtptime: 3032184797, ntptime: 9223372036854775808, ntpnstime: 596523:14:08.000000000

Here is the one captured with ffmpeg 2.7.2:

0:00:50.725134082 Received RTCP SR packet SSRC: 2102232704, rtptime: 2173288374, ntptime: 15799514243063691084, ntpnstime: 1021836:24:30.631000000
0:00:55.757820842 Received RTCP SR packet SSRC: 2102232704, rtptime: 2173741254, ntptime: 15799514264675966517, ntpnstime: 1021836:24:35.662999999
0:01:00.760914175 Received RTCP SR packet SSRC: 2102232704, rtptime: 2174191524, ntptime: 15799514286163687899, ntpnstime: 1021836:24:40.665999999
0:01:05.793591156 Received RTCP SR packet SSRC: 2102232704, rtptime: 2174644494, ntptime: 15799514307780258300, ntpnstime: 1021836:24:45.699000000
0:01:10.819718742 Received RTCP SR packet SSRC: 2102232704, rtptime: 2175096834, ntptime: 15799514329366763930, ntpnstime: 1021836:24:50.725000000

How to reproduce:

% ffmpeg -re -i -an -vcodec libx264 -profile:v baseline -level 3.0 -f rtp rtp://SERVER_IP:PORT
ffmpeg version 2.8.6
built on ubuntu xenial

Change History (3)

comment:1 Changed 2 years ago by cehoyos

  • Keywords rtp regression added
  • Priority changed from normal to important

Is this issue reproducible with current FFmpeg git head?

comment:2 Changed 2 years ago by sancane

Just tried it.

It seems that the problem is solved in git head. Sorry for the noise.

Regards

comment:3 Changed 2 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

If you want this fixed in old release series, please tell us which commit fixed the issue.

Note: See TracTickets for help on using tickets.