Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#5703 closed defect (fixed)

compile error when disable bitstrem filters

Reported by: vlad2005 Owned by:
Priority: important Component: avcodec
Version: git-master Keywords: lame regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

When configure with "--disable-bsfs" i got error:

CC	ffmpeg_dxva2.o
LD	ffmpeg_g.exe
libavcodec/libavcodec.a(mpegaudiodecheader.o): In function `avpriv_mpegaudio_decode_header':
/home/user/software/ffmpeg-20160710-d4c8e93/libavcodec/mpegaudiodecheader.c:59: undefined reference to `avpriv_mpa_freq_tab'
/home/user/software/ffmpeg-20160710-d4c8e93/libavcodec/mpegaudiodecheader.c:80: undefined reference to `avpriv_mpa_bitrate_tab'
/home/user/software/ffmpeg-20160710-d4c8e93/libavcodec/mpegaudiodecheader.c:59: undefined reference to `avpriv_mpa_freq_tab'
/home/user/software/ffmpeg-20160710-d4c8e93/libavcodec/mpegaudiodecheader.c:80: undefined reference to `avpriv_mpa_bitrate_tab'
/home/user/software/ffmpeg-20160710-d4c8e93/libavcodec/mpegaudiodecheader.c:59: undefined reference to `avpriv_mpa_freq_tab'
/home/user/software/ffmpeg-20160710-d4c8e93/libavcodec/mpegaudiodecheader.c:80: undefined reference to `avpriv_mpa_bitrate_tab'
/home/user/software/ffmpeg-20160710-d4c8e93/libavcodec/mpegaudiodecheader.c:59: undefined reference to `avpriv_mpa_freq_tab'
/home/user/software/ffmpeg-20160710-d4c8e93/libavcodec/mpegaudiodecheader.c:80: undefined reference to `avpriv_mpa_bitrate_tab'
collect2: error: ld returned 1 exit status
make: *** [ffmpeg_g.exe] Error 1

This is full config command:

./configure \
--pkg-config=pkg-config \
--pkg-config-flags="--static" \
--extra-cflags=${CFLAGS} \
--extra-ldflags=${LDFLAGS} \
--prefix="/home/user/software/packages/win32" \
--enable-memalign-hack --arch=x86 --target-os=mingw32 \
--cross-prefix=i686-w64-mingw32- \
--enable-yasm \
--enable-gpl \
--enable-libmp3lame \
--enable-outdev=sdl \
--enable-sdl \
--disable-shared --enable-static \
--disable-doc \
--disable-htmlpages \
--disable-manpages \
--disable-podpages \
--disable-txtpages \
--disable-ffplay \
--disable-ffprobe \
--disable-ffserver \
--disable-demuxers --enable-demuxer=rawvideo,pcm_s* \
--disable-muxers --enable-muxer=avi,h263,rawvideo \
--disable-encoders --enable-encoder=mpeg4,libmp3lame,rawvideo \
--disable-decoders --enable-decoder=rawvideo,pcm_s* \
--disable-protocols --enable-protocol=file \
--disable-indevs --enable-indev=dshow \
--disable-outdevs --enable-outdev=sdl \
--disable-parsers \
--disable-schannel --disable-securetransport --enable-small --disable-debug \
--enable-libfreetype --enable-libfontconfig \
--disable-filters --enable-filter=drawtext,volume,scale,aresample \
--disable-bsfs

When remove line that disable bsfs, compile was ok.

Change History (3)

comment:1 Changed 3 years ago by cehoyos

  • Keywords libmp3lame regression added; cross compile mingw32 removed
  • Priority changed from normal to important
  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from new to closed
  • Version changed from unspecified to git-master

Regression since eadd4264 - should be fixed in 244d22452c7d40891627e5f7e376558d6b5d8582 - thank you for the report!

comment:2 Changed 3 years ago by vlad2005

Ok, thanks!
Is fixed!

comment:3 Changed 2 years ago by cehoyos

  • Keywords lame added; libmp3lame removed
Note: See TracTickets for help on using tickets.