Opened 3 years ago

Closed 3 years ago

#5529 closed defect (fixed)

Unable to decode some H.264 stream after last changes

Reported by: Aleksoid1978 Owned by:
Priority: important Component: avcodec
Version: git-master Keywords: h264 regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Link to file - https://yadi.sk/i/SwTnylRerayJL
Summary of the bug: after latest changes in H.264 decoding some interlaced stream can't decoding.
How to reproduce:

D:\Download\ffmpeg-20160508-git-38eeb85-win32-static\bin>ffplay.exe "H.264 interlaced.mp4"
ffplay version N-79883-g38eeb85 Copyright (c) 2003-2016 the FFmpeg developers
  built with gcc 5.3.0 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libfreetype --enable-libgme --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmfx --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-libzimg --enable-lzma --enable-decklink --enable-zlib
  libavutil      55. 24.100 / 55. 24.100
  libavcodec     57. 40.100 / 57. 40.100
  libavformat    57. 36.100 / 57. 36.100
  libavdevice    57.  0.101 / 57.  0.101
  libavfilter     6. 45.100 /  6. 45.100
  libswscale      4.  1.100 /  4.  1.100
  libswresample   2.  0.101 /  2.  0.101
  libpostproc    54.  0.100 / 54.  0.100
[h264 @ 06036ce0] Invalid NAL unit size.q=    0KB sq=    0B f=0/0
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit 0, skipping.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit 0, skipping.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit 0, skipping.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit 0, skipping.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit 0, skipping.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit 0, skipping.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit 0, skipping.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit 0, skipping.KB sq=    0B f=0/0
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit 0, skipping.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit 0, skipping.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit 0, skipping.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit 0, skipping.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit 0, skipping.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit 0, skipping.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit 0, skipping.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit 0, skipping.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit 0, skipping.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit size.
[h264 @ 06036ce0] Error splitting the input into NAL units.
[h264 @ 06036ce0] Invalid NAL unit 0, skipping.
[h264 @ 06036ce0] Error splitting the input into NAL units.}}}

Attachments (1)

H.264 interlaced_cut.mp4 (2.4 MB) - added by cehoyos 3 years ago.

Change History (4)

comment:1 Changed 3 years ago by cehoyos

  • Keywords h264 regression added; H.264 interlaced removed
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open

Regression since 772ad714 / ca2f19b9

Changed 3 years ago by cehoyos

comment:3 Changed 3 years ago by heleppkes

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.