Opened 19 months ago

Closed 19 months ago

Last modified 19 months ago

#5524 closed defect (duplicate)

enabled/disabled audiotracks

Reported by: rodion Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug: aac is disabled as default, ac3 is enabled
according to Apple it is not correct https://developer.apple.com/library/mac/qa/qa1604/_index.html
How to reproduce:

% ./ffmpeg  -i "Extracted Stream Video.m2v" -i "Extracted Stream Audio.ac3"  -map 0:v -vcodec h264 -map 1:a -c:a:0 aac -map 1:a -c:a:1 copy "Output.m4v"
ffmpeg version 3.0.2-tessus Copyright (c) 2000-2016 the FFmpeg developers
  built with Apple LLVM version 6.0 (clang-600.0.57) (based on LLVM 3.5svn)

Patches should be submitted to the ffmpeg-devel mailing list and not this bug tracker.

Attachments (1)

Снимок экрана 2016-05-09 в 7.29.25.png (55.5 KB) - added by rodion 19 months ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 19 months ago by rodion

/Volumes/Macintosh?\ HD2/Новая\ папка/FFMpeg/ffmpeg /Volumes/Macintosh?\ HD2/Новая\ папка/FFMpeg/Output.m4v
ffmpeg version 3.0.2-tessus Copyright (c) 2000-2016 the FFmpeg developers

built with Apple LLVM version 6.0 (clang-600.0.57) (based on LLVM 3.5svn)
configuration: --cc=/usr/bin/clang --prefix=/opt/ffmpeg --as=yasm --extra-version=tessus --enable-avisynth --enable-fontconfig --enable-gpl --enable-libass --enable-libbluray --enable-libfreetype --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopus --enable-libschroedinger --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libvidstab --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-libzmq --enable-version3 --disable-ffplay --disable-indev=qtkit --disable-indev=x11grab_xcb
libavutil 55. 17.103 / 55. 17.103
libavcodec 57. 24.102 / 57. 24.102
libavformat 57. 25.100 / 57. 25.100
libavdevice 57. 0.101 / 57. 0.101
libavfilter 6. 31.100 / 6. 31.100
libswscale 4. 0.100 / 4. 0.100
libswresample 2. 0.101 / 2. 0.101
libpostproc 54. 0.100 / 54. 0.100

Output #0, ipod, to '/Volumes/Macintosh? HD2/Новая папка/FFMpeg/Output.m4v':

Output file #0 does not contain any stream

Mac-Pro-Rodion:~ rodion$

comment:2 Changed 19 months ago by cehoyos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of ticket #3622.

comment:3 Changed 19 months ago by rodion

does it mean that end-user must recompile the program from sources with the patch to make it useable?
Thanks a lot!

comment:4 Changed 19 months ago by cehoyos

I am not sure if I know which patch you want to test but to the best of my knowledge there is no real fix, just workarounds that depend on your exact use case.

Note: See TracTickets for help on using tickets.