Opened 2 years ago

Closed 22 months ago

#5421 closed defect (fixed)

Encoder is no longer displayed, qp range is wrong

Reported by: michael Owned by:
Priority: important Component: undetermined
Version: git-master Keywords: codecpar regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no


./ffmpeg-ref -i matrixbench_mpeg2.mpg out.h264
Stream #0:0: Video: h264 (libx264), yuv420p, 720x576 [SAR 16:15 DAR 4:3], q=-1--1, 25 fps, 25 tbn, 25 tbc
./ffmpeg -i matrixbench_mpeg2.mpg out.h264
Stream #0:0: Video: h264, yuv420p, 720x576 [SAR 16:15 DAR 4:3], q=2-31, 25 fps, 25 tbn

the 2-31 qp range is an mpeg range likely not what the h264 encoder uses

Change History (3)

comment:1 Changed 2 years ago by heleppkes

From a quick inspection this happens because ffmpeg.c prints using the muxer context, instead of printing the actual encoder contexts - and the muxer only has codecpar information now, which doesn't contain any more than shown here.

When ffmpeg.c is updated to codecpar, printing of the output streams should be changed to use the actual encoding context instead.

comment:2 Changed 2 years ago by cehoyos

  • Keywords regression added
  • Priority changed from normal to important
  • Version changed from unspecified to git-master

comment:3 Changed 22 months ago by michael

  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.