Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#5365 closed defect (duplicate)

Support for Resampler of Core Audio of OSX

Reported by: ponpon Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

thank ffmpeg team for the good app.

i have known the support for encoder/decoder with core audio of osx from ticket #4828.

seeing the patch, AudioConverter.h is used. though AudioConverter.h supports for resampling, eg. kAudioConverterSampleRateConverterComplexity, kAudioConverterSampleRateConverterQuality, kAudioConverterSampleRateConverterInitialPhase, kAudioConverterPrimeMethod, kAudioConverterPropertyDithering, kAudioConverterPropertyDitherBitDepth, these aren't supported in the patch.

i request support for resampling of core audio.

Change History (3)

comment:1 follow-up: Changed 3 years ago by cehoyos

  • Resolution set to duplicate
  • Status changed from new to closed

Feel free to reopen this ticket if ticket #5366 gets implemented without an audio resampler.

comment:2 Changed 3 years ago by gjdfgh

One question: why????

FFmpeg provides a good resampler, and can even support the sox resampler.

comment:3 in reply to: ↑ 1 Changed 3 years ago by ponpon

Replying to cehoyos:
it is a good idea because audio unit has AUConverter. it may depend on audio quality and the design of ffmpeg which is it implemented on or both.

to gjdfgh
it is used on playback audio of osx or ios. its quality is excellent. why do professional musicians want to use mac?

Note: See TracTickets for help on using tickets.