Opened 6 years ago

Closed 5 years ago

#5342 closed defect (fixed)

Stuttering issue with ffplay (with SDL)

Reported by: Eddy Owned by:
Priority: normal Component: ffplay
Version: git-master Keywords: SDL
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Hi everyone,

I have some stuttering issues using ffplay with compressed videos. It appears randomly during the playback. It seems to work perfectly with VLC.

To reproduce the problem, I generated some patterns with a moving text. I encoded the video with 3 differents frame rate and I have the problem every time.

My command line is very simple : ffplay.exe -i black_720p50.ts

Hope you can reproduce the problem on your side.

Thanks,

Eddy

Attachments (3)

black_720p59.94.ts (2.0 MB ) - added by Eddy 6 years ago.
black_720p50.ts (1.7 MB ) - added by Eddy 6 years ago.
black_720p60.ts (2.0 MB ) - added by Eddy 6 years ago.

Change History (7)

by Eddy, 6 years ago

Attachment: black_720p59.94.ts added

by Eddy, 6 years ago

Attachment: black_720p50.ts added

by Eddy, 6 years ago

Attachment: black_720p60.ts added

comment:1 by Marton Balint, 6 years ago

SDL Xvideo support in windows is very bad, it is not capable of handling that high fps. This is a wontfix until we move to SDL2 which (most probably) has much better 2d video support.

comment:2 by Eddy, 6 years ago

I have the same troubles on Linux (Ubuntu).

I was wondering about the accuracy of the time measurement. When you're playing a video, you need to measure the time with an accuracy of at least 1ms.

I know that depending on the OS you cannot have this accuracy. So i began to wonder if this was the cause of the stuttering issues. Don't we need to implement a kind of regulation system based on the clock presicion of the OS ?

Last edited 6 years ago by Eddy (previous) (diff)

comment:3 by Marton Balint, 6 years ago

I don't think it is time measurement. To figure out if this is really an ffplay issue please try VLC on Linux with the video output driver set to Xvideo.

comment:4 by Marton Balint, 5 years ago

Resolution: fixed
Status: newclosed

New ffplay in git master is using SDL2 for video render, this should improve this. Reopen, if you still experience problems.

Note: See TracTickets for help on using tickets.