Opened 2 years ago

Last modified 2 years ago

#5260 new defect

Issue while Playing Media File with RTSP Url using FFPLAY

Reported by: bilalahmed54 Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: dts
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I am playing the media fileby fetching the streams directly from some server with FFPLAY. I am using the following command:

ffplay rtsp://media:123456@xx.xx.xxx.xx/archive/123456789

But, After executing this command, I am getting the following error messages continously on CMD:

[rtsp @ 00000000005417e0] DTS discontinuity in stream 1: packet 1149 with DTS 36
47680, packet 1150 with DTS 4058000

Can anyone please tell me that when this error is produced? Is there any reason behind this and any workaround for this?

Attachments (2)

LiveMon_Customer_FFMPEG.png (48.5 KB) - added by bilalahmed54 2 years ago.
Producing this issue with FFMPEG Command
LiveMon_Customer_FFPLAY.png (77.5 KB) - added by bilalahmed54 2 years ago.
Producing this issue with FFPLAY Command with Complete Output

Download all attachments as: .zip

Change History (6)

comment:1 follow-up: Changed 2 years ago by cehoyos

  • Keywords ffplay removed
  • Priority changed from important to normal

Is the issue not reproducible with ffmpeg?
Please provide command line including complete, uncut console output to make this a valid ticket.

Changed 2 years ago by bilalahmed54

Producing this issue with FFMPEG Command

Changed 2 years ago by bilalahmed54

Producing this issue with FFPLAY Command with Complete Output

comment:2 in reply to: ↑ 1 Changed 2 years ago by bilalahmed54

This issue can be reproduced with FFMPEG command as well. And I have attached the complete console output as well. Please See the attached images:

Replying to cehoyos:

Is the issue not reproducible with ffmpeg?
Please provide command line including complete, uncut console output to make this a valid ticket.

comment:3 Changed 2 years ago by bilalahmed54

  • Component changed from ffplay to ffmpeg

comment:4 Changed 2 years ago by cehoyos

  • Component changed from ffmpeg to undetermined
$ ffmpeg -i rtsp://media:123456@10.10.167.20/41715308bd19c32
ffmpeg version N-78615-g1001674 Copyright (c) 2000-2016 the FFmpeg developers
  built with gcc 4.7 (SUSE Linux)
  configuration: --enable-gpl
  libavutil      55. 18.100 / 55. 18.100
  libavcodec     57. 24.105 / 57. 24.105
  libavformat    57. 26.100 / 57. 26.100
  libavdevice    57.  0.101 / 57.  0.101
  libavfilter     6. 34.100 /  6. 34.100
  libswscale      4.  0.100 /  4.  0.100
  libswresample   2.  0.101 /  2.  0.101
  libpostproc    54.  0.100 / 54.  0.100
[tcp @ 0x3bc8380] Connection to tcp://10.10.167.20:554?timeout=0 failed: Connection timed out
rtsp://media:123456@10.10.167.20/41715308bd19c32: Connection timed out

How can I reproduce the issue?
Please do not post screen shots, always paste the complete, uncut console output.

Note: See TracTickets for help on using tickets.