Opened 2 years ago

Closed 2 years ago

#5175 closed defect (wontfix)

Performance Regression: AVI to WEBM Conversion

Reported by: horstr Owned by:
Priority: normal Component: avformat
Version: unspecified Keywords: webm
Cc: stefan.kaltenberger@fabasoft.com Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

After switching from 2.4.3 to 2.8.4, the conversion from AVI to WEBM takes significantly longer to complete (8 seconds vs. 61 seconds). The output size is more or less identical.

How to reproduce:

ffmpeg -f avi -i test.avi -acodec libvorbis -ac 2 -y test.webm

The sample file "test.avi" is attached.

2.4.3:

ffmpeg-old --version
ffmpeg version 2.4.3- http://johnvansickle.com/ffmpeg/ Copyright (c) 2000-2014 the FFmpeg developers

built on Nov 4 2014 13:14:24 with gcc 4.8 (Debian 4.8.3-13)
configuration: --enable-gpl --enable-version3 --disable-shared --disable-debug --enable-runtime-cpudetect --enable-libmp3lame --enable-libx264 --enable-libx265 --enable-libwebp --enable-libspeex --enable-libvorbis --enable-libvpx --enable-libfreetype --enable-fontconfig --enable-libxvid --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-gray --enable-libopenjpeg --enable-libopus --disable-ffserver --enable-libass --enable-gnutls --cc=gcc-4.8
libavutil 54. 7.100 / 54. 7.100
libavcodec 56. 1.100 / 56. 1.100
libavformat 56. 4.101 / 56. 4.101
libavdevice 56. 0.100 / 56. 0.100
libavfilter 5. 1.100 / 5. 1.100
libswscale 3. 0.100 / 3. 0.100
libswresample 1. 1.100 / 1. 1.100
libpostproc 53. 0.100 / 53. 0.100

$ ffmpeg-old -f avi -i test.avi -acodec libvorbis -ac 2 -y test.webm && ls -l test.webm
real 0m8.219s
user 0m8.177s
sys 0m0.031s
-rw-r--r--. 1 root root 158993 Jan 20 14:52 test.webm

2.8.4:

ffmpeg --version
ffmpeg version 2.8.4-static http://johnvansickle.com/ffmpeg/ Copyright (c) 2000-2015 the FFmpeg developers

built with gcc 4.9.3 (Debian 4.9.3-10)
configuration: --enable-gpl --enable-version3 --disable-shared --disable-debug --enable-runtime-cpudetect --enable-libmp3lame --enable-libx264 --enable-libx265 --enable-libwebp --enable-libspeex --enable-libvorbis --enable-libvpx --enable-libfreetype --enable-fontconfig --enable-libxvid --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-gray --enable-libopenjpeg --enable-libopus --enable-libass --enable-gnutls --enable-libvidstab --enable-libsoxr --enable-frei0r --enable-libfribidi --disable-indev=sndio --disable-outdev=sndio --cc=gcc-4.9
libavutil 54. 31.100 / 54. 31.100
libavcodec 56. 60.100 / 56. 60.100
libavformat 56. 40.101 / 56. 40.101
libavdevice 56. 4.100 / 56. 4.100
libavfilter 5. 40.101 / 5. 40.101
libswscale 3. 1.101 / 3. 1.101
libswresample 1. 2.101 / 1. 2.101
libpostproc 53. 3.100 / 53. 3.100

$ ffmpeg -f avi -i test.avi -acodec libvorbis -ac 2 -y test.webm && ls -l test.webm
real 1m1.653s
user 1m1.439s
sys 0m0.132s
-rw-r--r--. 1 root root 174055 Jan 20 14:54 test.webm

Change History (3)

comment:1 Changed 2 years ago by horstr

test.avi:

http://www.engr.colostate.edu/me/facil/dynamics/files/bird.avi

In case of this file, the difference is as follows:

2.4.3:

real 0m7.629s
user 0m7.483s
sys 0m0.056s

2.8.4:

real 0m25.218s
user 0m25.021s
sys 0m0.109s

comment:2 Changed 2 years ago by heleppkes

WebM changed its default to VP9 encoding some time ago, and speed in different codecs is different. For an actual comparison switch it back to vp8

Last edited 2 years ago by heleppkes (previous) (diff)

comment:3 Changed 2 years ago by cehoyos

  • Component changed from avcodec to avformat
  • Keywords avi removed
  • Resolution set to wontfix
  • Status changed from new to closed

This is the intended behaviour if you do not specify a video encoder.

Note: See TracTickets for help on using tickets.