Opened 5 years ago

Closed 5 years ago

#509 closed defect (needs_more_info)

Non monotonically increasing dts to muxer in stream

Reported by: Gagan Owned by:
Priority: normal Component: avcodec
Version: 0.8.4 Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I am working on 0.8.4 "Love" libraries with IPhone os sdk 4.3. But when i run the code i am getting following error for my audio stream. I am trying to compress .mov video file to .mp4 file in IPhone. I am getting result video with shorter length by few seconds (loosing some audio frames i guess) and audio is .5 sec faster than video. I read somewhere "non monotonically ....." is reported bug which is not yet solved. I would like to know whether this is happening due to some existing bug or i am missing something in code ? Please find attached my app console output for reference.

[mp4 @ 0x10e6800] Application provided invalid, non monotonically increasing dts to muxer in stream 1: 2048 >= 2048

Attachments (1)

ConsoleOutput.rtf (133.4 KB) - added by Gagan 5 years ago.
Console Output while compressing .mov to .mp4 in IPhone

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by Gagan

Console Output while compressing .mov to .mp4 in IPhone

comment:1 Changed 5 years ago by cehoyos

Please test current ffmpeg (the application), provide complete, uncut output and a sample.

comment:2 Changed 5 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

Please reopen if you can provide a sample.

Note: See TracTickets for help on using tickets.