Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#508 closed defect (invalid)

transcoding to mp4 with ffmpeg fails reliably

Reported by: graylion Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

in this example I tried to transcode a mkv with h264 and dca to mp4 and ac3. The commandline was:

ffmpeg -i Excalibur\ 1981.mkv -sameq -vcodec mpeg4 -pass 1 -threads 4 -b 10000000 -an -f mp4 -y /dev/nul

the next step would have been:

ffmpeg -i Excalibur\ 1981.mkv -sameq -vcodec mpeg4 -pass 2 -threads 4 -b 10000000 -acodec ac3 -ab 384000 -f mp4 Excalibur.mp4

after some procerssing I got the following error:

av_interleaved_write_frame(): Error while opening file bitrate=12810.9kbits/s

the output you asked for is here:

#ffmpeg -v 9 -loglevel 99 -i Excalibur\ 1981.mkv
FFmpeg version SVN-r0.5.1-4:0.5.1-1ubuntu1.2, Copyright (c) 2000-2009 Fabrice Bellard, et al.

configuration: --extra-version=4:0.5.1-1ubuntu1.2 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --disable-stripping --disable-vhook --enable-runtime-cpudetect --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdc1394 --enable-shared --disable-static
libavutil 49.15. 0 / 49.15. 0
libavcodec 52.20. 1 / 52.20. 1
libavformat 52.31. 0 / 52.31. 0
libavdevice 52. 1. 0 / 52. 1. 0
libavfilter 0. 4. 0 / 0. 4. 0
libswscale 0. 7. 1 / 0. 7. 1
libpostproc 51. 2. 0 / 51. 2. 0
built on Sep 16 2011 17:08:44, gcc: 4.4.3

ffmpeg: unrecognized option '-loglevel'

This used to work without any problems until about a month ago, now it fails reliably. sometimes in first pass, sometimes in second, but it will fail.

OS is Ubuntu Lucid 10.04.3

Change History (2)

comment:1 Changed 5 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed

The version you are testing is ancient.

Please retry with current git head - you can find snapshots on http://ffmpeg.org/download.html if you don't like git - and reopen if the problem is still reproducible.

comment:2 Changed 5 years ago by llogan

Some additional comments: -sameq and -b options are mutually exclusive. FFmpeg probably ignores your -sameq anyway which is good because your input and output don't share the same quantizer scale. Also, you either cut off the end of your paste, or you misspelled /dev/null.

See HOWTO: Install and use the latest FFmpeg and x264 for step-by-step instructions to compile FFmpeg in Ubuntu.

Note: See TracTickets for help on using tickets.