Opened 9 years ago

Closed 9 years ago

Last modified 22 months ago

#5054 closed defect (duplicate)

TrueHD Decoder not lossless

Reported by: marcusj0015 Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

The sample is exactly 1 minute long, 48000hz sample rate, 24 bits per
sample, 8 channels. and all samples are set to 0xFFFFFF

here's the thd sample, and here's one of the 8 mono wavs (they're all
literally the same, I manually created the file in a hex editor and copied
it for all the others.)

the thd was created with Dolby Media Encoder Standalone Edition.

Input.mlp is what ffmpeg decodes, to Output.wav.

Original.wav is the file fed into Dolby Media Encode Standalone Edition

Here are the files:

Input.mlp: https://www.dropbox.com/s/fvh9lie1ofryws0/Input.mlp

Output.wav: https://www.dropbox.com/s/vjfjgv1vu11uci4/Output.wav

Original.wav: https://www.dropbox.com/s/8s5n5lv4qtvzysw/Original.wav

The command line output is attached.

Attachments (1)

THDFail.log (40.7 KB ) - added by marcusj0015 9 years ago.
Command line output of TrueHD Decoding

Download all attachments as: .zip

Change History (3)

by marcusj0015, 9 years ago

Attachment: THDFail.log added

Command line output of TrueHD Decoding

comment:1 by Carl Eugen Hoyos, 9 years ago

Keywords: TrueHD lossless audio decoder removed
Resolution: duplicate
Status: newclosed

Looks like a duplicate if ticket #5039.

comment:2 by Balling, 22 months ago

Last edited 22 months ago by Balling (previous) (diff)
Note: See TracTickets for help on using tickets.