Opened 3 years ago

Closed 3 years ago

#5044 closed defect (fixed)

overflow in mpegtsenc cbr period calculations

Reported by: fabled Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: mpegts
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

ts->mux_rate is int (signed 32-bit) type. many of the calculations will overflow when mux_rate > 5mbps.
see attached patch to use av_rescale instead.

Attachments (1)

fix-mpegtsenc-cbr-scaling.patch (1.1 KB) - added by fabled 3 years ago.
fix

Download all attachments as: .zip

Change History (4)

Changed 3 years ago by fabled

fix

comment:1 Changed 3 years ago by cehoyos

  • Keywords mpegts added

Please either:

  • send your patch made with git format-patch to the FFmpeg development mailing list where it can be discussed, patches are ignored on this bug tracker.

or

  • provide a command line that allows to reproduce the issue you'd like to fix together with the complete, uncut console output testing current FFmpeg git head to make this a valid ticket.

comment:2 Changed 3 years ago by fabled

Oh, seems the policy changed since I last submitted something (ages ago). Patch sent on the devel list mailing address.

comment:3 Changed 3 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from new to closed
  • Version changed from unspecified to git-master

Thank you, your patch was applied as 64f7db554ee83846f207e82a08946a6a5a6acfe2

Note: See TracTickets for help on using tickets.