Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#5043 closed defect (fixed)

Latest aac_tablegen.h breaks build on OS X

Reported by: f77hacker Owned by:
Priority: important Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
aacenc.c:989:49: error: use of undeclared

identifier 'ff_aac_tableinit'; did you mean 'aac_table_init'?

if ((ret = ff_thread_once(&aac_table_init, &ff_aac_tableinit)) != 0)

How to reproduce:

configure ${FFMPEG_build}
  FFMPEG_build='--enable-logging '
  FFMPEG_build+='--prefix=/Users/me/myLocal/ffmpeg '
  FFMPEG_build+='--cc=clang '
  FFMPEG_build+='--arch=x86_64 '
  FFMPEG_build+='--enable-gpl '
  FFMPEG_build+='--enable-version3 '
  FFMPEG_build+='--enable-nonfree '
  FFMPEG_build+='--enable-shared '
  FFMPEG_build+='--enable-pthreads '
  FFMPEG_build+='--enable-opencl '
  FFMPEG_build+='--enable-opengl '
  FFMPEG_build+='--enable-libzmq '
  FFMPEG_build+='--disable-small '
  FFMPEG_build+='--disable-runtime-cpudetect '
  FFMPEG_build+='--disable-fast-unaligned '
  FFMPEG_build+='--enable-memalign-hack '
  FFMPEG_build+='--enable-gray '
  FFMPEG_build+='--enable-swscale-alpha '
  FFMPEG_build+='--enable-ffmpeg '
  FFMPEG_build+='--enable-ffplay '
  FFMPEG_build+='--enable-ffprobe '
  FFMPEG_build+='--enable-ffserver '
  FFMPEG_build+='--disable-doc '
  FFMPEG_build+='--disable-htmlpages '
  FFMPEG_build+='--disable-manpages '
  FFMPEG_build+='--disable-podpages '
  FFMPEG_build+='--disable-txtpages '
  FFMPEG_build+='--enable-avdevice '
  FFMPEG_build+='--enable-avcodec '
  FFMPEG_build+='--enable-avformat '
  FFMPEG_build+='--enable-avutil '
  FFMPEG_build+='--enable-swresample '
  FFMPEG_build+='--enable-swscale '
  FFMPEG_build+='--enable-postproc '
  FFMPEG_build+='--enable-avfilter '
  FFMPEG_build+='--enable-avresample '
  FFMPEG_build+='--enable-pthreads '
  FFMPEG_build+='--enable-network '
  FFMPEG_build+='--enable-openssl '
  FFMPEG_build+='--enable-sdl '
  FFMPEG_build+='--enable-vda '
  FFMPEG_build+='--disable-avisynth '
  FFMPEG_build+='--enable-asm '
  FFMPEG_build+='--as=/Users/me/abrew/bin/nasm '
  FFMPEG_build+='--doxygen=/Users/me/abrew/bin/doxygen '
  FFMPEG_build+='--pkg-config=/Users/me/myLocal/bin/pkg-config '
  FFMPEG_build+='--enable-bzlib '
  FFMPEG_build+='--enable-fontconfig '
  FFMPEG_build+='--enable-zlib '
  FFMPEG_build+='--enable-pic '
  FFMPEG_build+='--disable-symver '
  FFMPEG_build+='--enable-hardcoded-tables '
  FFMPEG_build+='--disable-debug '
  FFMPEG_build+='--enable-stripping '
  FFMPEG_build+='--disable-extra-warnings '
  FFMPEG_build+="--extra-version=${now} "
  FFMPEG_build+='--disable-x11grab '
  FFMPEG_build+='--enable-frei0r '
  FFMPEG_build+='--enable-libfaac '
  FFMPEG_build+='--enable-libfdk-aac '
  FFMPEG_build+='--enable-libfreetype '
  FFMPEG_build+='--enable-libfribidi '
  FFMPEG_build+='--enable-libgsm '
  FFMPEG_build+='--enable-libmp3lame '
  FFMPEG_build+='--enable-libopencore-amrwb '
  FFMPEG_build+='--enable-libopencore-amrnb '
  FFMPEG_build+='--enable-libopencv '
  FFMPEG_build+='--enable-libopenh264 '
  FFMPEG_build+='--enable-libopenjpeg '
  FFMPEG_build+='--enable-libopus '
  FFMPEG_build+='--enable-libpulse '
  FFMPEG_build+='--enable-librtmp '
  FFMPEG_build+='--enable-libquvi '
  FFMPEG_build+='--enable-libschroedinger '
  FFMPEG_build+='--enable-libsnappy '
  FFMPEG_build+='--enable-libsoxr '
  FFMPEG_build+='--enable-libspeex '
  FFMPEG_build+='--enable-libtheora '
  FFMPEG_build+='--enable-libvidstab '
  FFMPEG_build+='--enable-libvo-aacenc '
  FFMPEG_build+='--enable-libvorbis '
  FFMPEG_build+='--enable-libvpx '
  FFMPEG_build+='--enable-libwavpack '
  FFMPEG_build+='--enable-libx264 '
  FFMPEG_build+='--enable-libx265 '
  FFMPEG_build+='--enable-libxvid '
  FFMPEG_build+='--extra-libs=-L/Users/glen/abrew/lib '
  FFMPEG_build+='--enable-libdcadec '
  FFMPEG_build+='--enable-libkvazaar '
	FFMPEG_build+='--enable-libass '
	FFMPEG_build+='--enable-libbluray '
	FFMPEG_build+='--enable-libcaca '

/dev/ffmpeg/libavcodec/aacenc.c:989:49: error: use of undeclared
      identifier 'ff_aac_tableinit'; did you mean 'aac_table_init'?
    if ((ret = ff_thread_once(&aac_table_init, &ff_aac_tableinit)) != 0)

Change History (5)

comment:1 Changed 3 years ago by f77hacker

I rolled back to previous head and compiles without problems.

comment:2 Changed 3 years ago by Timothy_Gu

  • Resolution set to fixed
  • Status changed from new to closed

Hi, this bug has been fixed in the latest FFmpeg: 591fbd629ef5fcff874a5cca8a9edd094f0c9ea4.

I would encourage you however to continue using the rolled-back version for another day or so, since some other problems have been recognized with that particular commit.

comment:3 Changed 3 years ago by f77hacker

ok thanks.

comment:4 Changed 3 years ago by f77hacker

ok thanks.

comment:5 Changed 3 years ago by cehoyos

  • Keywords libavcodec/aac_tablegen.h removed
Note: See TracTickets for help on using tickets.