Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#5007 closed enhancement (fixed)

Request of backport compatibility with libvpx 1.5 to release

Reported by: alextalker Owned by:
Priority: wish Component: avcodec
Version: git-master Keywords: libvpx
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Hello!

I'm user Arch Linux distro and because current release is incompatible with libvpx 1.5 API(but that's fixed in master branch already) people here will use i.e. custom package from AUR to keep their systems usable. I'll appreciate if somebody make a backport the compatibility for current release, so that Arch maintaiters could apply it to their package in repo. Thanks anyway!

Attachments (1)

ffmpeg.log (15.2 KB) - added by alextalker 3 years ago.
Log of makepkg -s for ffmpeg-full package(AUR)

Download all attachments as: .zip

Change History (6)

Changed 3 years ago by alextalker

Log of makepkg -s for ffmpeg-full package(AUR)

comment:1 Changed 3 years ago by cehoyos

  • Keywords avcodec removed
  • Priority changed from important to wish
  • Resolution set to wontfix
  • Status changed from new to closed
  • Type changed from defect to enhancement

This is impossible because users generally will expect that all 2.8.x version use the same versions of external libraries.
Feel free to send a patch that allows 2.8.3 to work with both old and new versions of libvpx.

comment:2 Changed 3 years ago by heleppkes

The patch from master makes it compatible with both old and new.

comment:3 Changed 3 years ago by heleppkes

The relevant commit should be 6540fe04a3f9a11ba7084a49b3ee5fa2fc5b32ab for reference.

comment:4 Changed 3 years ago by cehoyos

But weren't some of the defines usable in the past? If not, my comment is if course wrong.

comment:5 Changed 3 years ago by cehoyos

  • Resolution changed from wontfix to fixed

This will be fixed in 2.8.4.

Note: See TracTickets for help on using tickets.