Opened 3 years ago

Closed 3 years ago

#5006 closed defect (needs_more_info)

NVENC fails to encode/decode yuv420p

Reported by: dazwin Owned by:
Priority: normal Component: avcodec
Version: git-master Keywords: nvenc
Cc: reza@kwaaioak.com Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:

% ffmpeg -y -i video.mp4 -c:v nvenc -pix_fmt yuv420p video-nvenc-nv12.yuv

ffmpeg version a97f1e7bd0850dd768516b44822bbdde709aa24e
(built from source)

nVidia driver 346.22 running on Linux (g2.2xlarge on Amazon AWS)
NVENC SDK v5.0.1

Checked with -pix_fmt nv12 and it works Ok.

Debugging this a bit...
[nvenc @ 0x39f3520] CreateInputBuffer? failed: 10

So, this is because of NV_ENC_ERR_INVALID_CALL

Change History (2)

comment:1 Changed 3 years ago by cehoyos

Aren't you reporting this on the wrong bug tracker?

Please provide your failing command line together with the complete, uncut console output to make this a valid ticket.

comment:2 Changed 3 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

Feel free to reopen this ticket if you can provide the missing information.

Note: See TracTickets for help on using tickets.