Opened 5 years ago

Closed 5 years ago

#497 closed defect (invalid)

Error in compiling FFMPEG 0.8.4 for ios sdk 4.3

Reported by: Gagan Owned by:
Priority: normal Component: build system
Version: 0.8.4 Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I am getting error when i am compiling this new 0.8.4 version libraries for armv7 for ios 4.3 sdk. Older version was working fine. Please find attached log file and my build file.

Attachments (4)

build_armv7 (776 bytes) - added by Gagan 5 years ago.
Build File for IPhone 4.3 SDK armv7
config.log (73.1 KB) - added by Gagan 5 years ago.
Log file
build_armv7_working (895 bytes) - added by Gagan 5 years ago.
Working build file for older version FFMPEG
config.err (121.8 KB) - added by Gagan 5 years ago.
config file

Download all attachments as: .zip

Change History (13)

Changed 5 years ago by Gagan

Build File for IPhone 4.3 SDK armv7

Changed 5 years ago by Gagan

Log file

comment:1 Changed 5 years ago by cehoyos

  • Status changed from new to open
  • Version changed from 0.8.3 to 0.8.4

Could you add config.log for 0.8.3 (assuming this was the working version)?

If this really is a regression, please find the version introducing it.

Changed 5 years ago by Gagan

Working build file for older version FFMPEG

comment:2 Changed 5 years ago by Gagan

No this was not 8.3 it was more older version i don't know where to look for version. I recently created all .a file again successfully for this older version. It does not create any log file but successfully compile and create all .a files. Find attached build script for this working FFMPEG version. I saw that it creates config.mak file but new version does not create this file thats why new version fails.

comment:3 Changed 5 years ago by cehoyos

Please upload config.log for your older build.

Changed 5 years ago by Gagan

config file

comment:4 Changed 5 years ago by Gagan

This config.err was the only file which i found in my older version build. I am not sure whether this is same file or not which you are asking as there is no config.log file exists there, However it compiles correctly.

comment:5 Changed 5 years ago by cehoyos

(config.err was renamed to config.log some time ago.)
Could you confirm that the old version still compiles? (Is the file you uploaded new or did you find it in your archives?)

comment:6 Changed 5 years ago by Gagan

Yes i compile it yesterday and it compiles successfully and i am using these libraries in my IPhone project to compress .mov to .mp4, However i am facing issue in setting pts and dts while sync audio and video frames because currently i am getting non monotone timestamp errors while writing audio frames and loosing some frame so getting shorter output video...., but that is different story. I thought this is happening due to older ffmpeg version and try to compile for new version but it fails.

comment:7 Changed 5 years ago by cehoyos

Then I suggest you try git bisect to find the version that broke building FFmpeg.
("v0.6" could be a starting version.)

comment:8 Changed 5 years ago by Gagan

Now i am able to compile 0.8.4 successfully for ios sdk 4.3. But when i run the code i am getting following error. I am trying to compress .mov file to .mp4 file in IPhone. I am getting result video with shorter length by few seconds (loosing some audio frames) and audio is .5 sec faster than video. I read somewhere "non monotonically ....." is reported bug which is not yet solved. I would like to know whether this is happening due to some bug or i am missing something in code ?

[mp4 @ 0x10e6800] Application provided invalid, non monotonically increasing dts to muxer in stream 1: 2048 >= 2048

comment:9 Changed 5 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from open to closed

Anything you had to do to allow compilation?

Note: See TracTickets for help on using tickets.