Opened 5 years ago

Closed 5 years ago

#49 closed defect (worksforme)

Ffmpeg gives error

Reported by: pranav_garg Owned by: michael
Priority: important Component: ffmpeg
Version: 0.6.90-rc0 Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I have recently installed FFMPEG on ubuntu 10.10 version with dual core.

I have used the following options to configure ffmpeg.

./configure --enable-gpl --enable-version3 --enable-nonfree --enable-postproc \
>     --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb \
>     --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis \
>     --enable-libvpx --enable-libx264 --enable-libxvid --enable-x11grab --enable-pthreads



When I use the command line for run ffmpeg, I get the error:

ffmpeg: relocation error: ffmpeg: symbol av_log_set_flags, version LIBAVUTIL_50 not defined in file libavutil.so.50 with link time reference

Change History (1)

comment:1 Changed 5 years ago by michael

  • Resolution set to worksforme
  • Status changed from new to closed

Ive tried on ubuntu 10.10 and i cannot reproduce this.
Please try make distclean
also make sure the excutable you run is the one you compiled

With the configure options you list, there should be no shared libs compiled and thus this error should be impossible

Note: See TracTickets for help on using tickets.