Opened 6 years ago

Closed 5 years ago

Last modified 23 months ago

#4767 closed enhancement (fixed)

support scc file of closed captioning data

Reported by: dave rice Owned by:
Priority: wish Component: avformat
Version: git-master Keywords: cc
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

Starting a ticket based on http://ffmpeg.org/pipermail/ffmpeg-user/2015-August/027836.html to support muxing scc files into supportive formats. I'm attaching an scc files and a corresponding srt files. The scc files contains some information that the srt doesn't, such as the placement coordinates and commands to rollup text, clear line, delete, etc.

Attachments (3)

SCIU04006_V2.scc (93.7 KB ) - added by dave rice 6 years ago.
scc file
SCIU04006_V2.srt (40.9 KB ) - added by dave rice 6 years ago.
srt file (same content as scc file)
SCIU04006_V2B.srt (47.7 KB ) - added by Marcelo Naumann Boufleur 6 years ago.
Newer version of SRT file, with fixes to Subrip syntax, and proper Timecode conversion from the SCC version.

Download all attachments as: .zip

Change History (13)

by dave rice, 6 years ago

Attachment: SCIU04006_V2.scc added

scc file

by dave rice, 6 years ago

Attachment: SCIU04006_V2.srt added

srt file (same content as scc file)

comment:1 by Carl Eugen Hoyos, 6 years ago

Component: undeterminedavformat
Keywords: cc added; scc captions removed
Priority: normalwish
Version: unspecifiedgit-master

by Marcelo Naumann Boufleur, 6 years ago

Attachment: SCIU04006_V2B.srt added

Newer version of SRT file, with fixes to Subrip syntax, and proper Timecode conversion from the SCC version.

comment:2 by Elon Musk, 5 years ago

Resolution: fixed
Status: newclosed

comment:3 by François, 5 years ago

Hi,

Does it mean that it is possible to extract SCC files from videos, for example using the following syntax ?

ffmpeg -f lavfi -i movie=ESPN_rtp.ts[out+subcc] -map 0:1 coucou.scc

I obtain the following message when I try: Unable to find a suitable output format for 'coucou.scc'

The same command works great with .srt output.

Do I have to enable a particular flag at compilation time ?

Thanks,

François

comment:4 by Elon Musk, 5 years ago

It would be easy to write scc muxer, but not ccaption encoder.

comment:5 by dave rice, 5 years ago

A scc muxer would be helpful for outputting a scc file from the output of the readeia608 filter. There are also encoded scc style captions in DV files and QuickTime c608 tracks so having a scc muxer could make this data a lot more accessible.

comment:6 by Elon Musk, 5 years ago

I need more files with closed captions embedded into video stream.
Because there is some nuisances with one file I already have.

comment:8 by Elon Musk, 5 years ago

Is there any tool that can already create reasonable scc files?

I wonder where to start and where to stop subtitle lines.

comment:9 by unsword, 3 years ago

Keywords: EIA-608 added

An SCC Muxer was added with this commit:
036e12b225b2869861d1449534dec94bd491559e

This command will now create a .scc file from source media containing EIA-608 Caption Data in userdata

ffmpeg.exe -f lavfi -i movie="CC_TEST001.mpg[out+subcc]" -map 0:1 -c:s copy T:\temp\output.scc

This provides creation of .scc from media containing captioning which is what this ticket morphed into.

The original request still exists to provide ability to use a .scc file as a source for inserting EIA-608 captioning as A/53 in MPEG-2 and x264 as well as 436M Ancillary Data of MXF files

Last edited 23 months ago by Carl Eugen Hoyos (previous) (diff)

comment:10 by Carl Eugen Hoyos, 23 months ago

Keywords: EIA-608 removed
Note: See TracTickets for help on using tickets.