Opened 3 years ago

Closed 3 years ago

#4697 closed defect (duplicate)

win32 - ffprobe ffmpeg, ansi path to JPG file - C:\тест\ interpreted as C:\╤В╨╡╤Б╤В\

Reported by: bayarookie Owned by:
Priority: minor Component: undetermined
Version: unspecified Keywords: win32
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:
C:\>"C:\Work\ffmpegGUIta\ffmpeg-2.7\ffprobe.exe" -show_streams C:\тест\SAM_0022.JPG
ffprobe version 2.7 Copyright (c) 2007-2015 the FFmpeg developers

built with gcc 4.9.2 (GCC)
configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libdcadec --enable-libfreetype --enable-libgme --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc

--enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-lzma --enable-decklink --enable-zlib

libavutil 54. 27.100 / 54. 27.100
libavcodec 56. 41.100 / 56. 41.100
libavformat 56. 36.100 / 56. 36.100
libavdevice 56. 4.100 / 56. 4.100
libavfilter 5. 16.101 / 5. 16.101
libswscale 3. 1.101 / 3. 1.101
libswresample 1. 2.100 / 1. 2.100
libpostproc 53. 3.100 / 53. 3.100

[image2 @ 03aaebc0] Could find no file with path 'C:\╤В╨╡╤Б╤В\SAM_0022.JPG' and index in the range 0-4
C:\╤В╨╡╤Б╤В\SAM_0022.JPG: No such file or directory

Change History (3)

comment:1 Changed 3 years ago by bayarookie

  • Keywords ansi added; unicode removed
  • Summary changed from win32 - ffprobe ffmpeg, unicode path to JPG file - Could find no file with path 'C:\╤В╨╡╤Б╤В\SAM_0022.JPG' to win32 - ffprobe ffmpeg, ansi path to JPG file - C:\тест\ interpreted as C:\╤В╨╡╤Б╤В\

comment:2 Changed 3 years ago by bayarookie

it works OK with png or any other formats

C:\>"C:\Work\ffmpegGUIta\ffmpeg-2.7\ffprobe.exe" -show_streams "C:\тест\SAM_0022
.png"
ffprobe version 2.7 Copyright (c) 2007-2015 the FFmpeg developers
  built with gcc 4.9.2 (GCC)
...
Input #0, png_pipe, from 'C:\╤В╨╡╤Б╤В\SAM_0022.png':

And if I get dos name, it works OK

C:\>dir /x
 Том в устройстве C не имеет метки.
 Серийный номер тома: 541F-5189

 Содержимое папки C:\

11.06.2009  00:42                24              autoexec.bat
11.06.2009  00:42                10              config.sys
04.07.2015  15:40    <DIR>                       DC
06.12.2014  17:23    <DIR>                       lazarus
14.07.2009  05:37    <DIR>                       PerfLogs
30.12.2014  12:01    <DIR>          PROGRA~1     Program Files
04.07.2015  15:36    <DIR>                       Temp
04.07.2015  15:42               164              test.bat
06.12.2014  17:16    <DIR>                       Users
26.05.2015  11:15    <DIR>                       Windows
06.12.2014  17:35    <DIR>                       Work
04.07.2015  15:42    <DIR>          FF6D~1       тест

C:\>"C:\Work\ffmpegGUIta\ffmpeg-2.7\ffprobe.exe" -show_streams "C:\FF6D~1\SAM_0022.JPG"

comment:3 Changed 3 years ago by cehoyos

  • Keywords JPG ansi path removed
  • Resolution set to duplicate
  • Status changed from new to closed

I believe this is a duplicate of ticket #819.

Note: See TracTickets for help on using tickets.