Opened 7 years ago

Closed 4 years ago

#4688 closed enhancement (fixed)

Support 12bit grayscale tif images

Reported by: Carl Eugen Hoyos Owned by:
Priority: wish Component: avcodec
Version: git-master Keywords: tif
Cc: ami_stuff@o2.pl Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Another sample reported by ami_stuff in ticket #3459:

$ ffmpeg -i 12bpp.tif
ffmpeg version N-73264-gb54ac84 Copyright (c) 2000-2015 the FFmpeg developers
  built with gcc 4.7 (SUSE Linux)
  configuration: --enable-gpl
  libavutil      54. 27.100 / 54. 27.100
  libavcodec     56. 45.101 / 56. 45.101
  libavformat    56. 40.100 / 56. 40.100
  libavdevice    56.  4.100 / 56.  4.100
  libavfilter     5. 19.100 /  5. 19.100
  libswscale      3.  1.101 /  3.  1.101
  libswresample   1.  2.100 /  1.  2.100
  libpostproc    53.  3.100 / 53.  3.100
[tiff @ 0x3aa72c0] This format is not supported (bpp=12, bppcount=1)
[tiff_pipe @ 0x3aa63e0] decoding for stream 0 failed
[tiff_pipe @ 0x3aa63e0] Could not find codec parameters for stream 0 (Video: tiff, none): unspecified size
Consider increasing the value for the 'analyzeduration' and 'probesize' options
12bpp.tif: could not find codec parameters
Input #0, tiff_pipe, from '12bpp.tif':
  Duration: N/A, bitrate: N/A
    Stream #0:0: Video: tiff, none, 25 tbr, 25 tbn, 25 tbc
At least one output file must be specified

Attachments (3)

12bpp.tif (1.1 MB ) - added by Carl Eugen Hoyos 7 years ago.
12bpp_lzw.tif (761.9 KB ) - added by Carl Eugen Hoyos 7 years ago.
12bpp_packbits.tif (1.0 MB ) - added by Carl Eugen Hoyos 7 years ago.

Change History (7)

by Carl Eugen Hoyos, 7 years ago

Attachment: 12bpp.tif added

by Carl Eugen Hoyos, 7 years ago

Attachment: 12bpp_lzw.tif added

by Carl Eugen Hoyos, 7 years ago

Attachment: 12bpp_packbits.tif added

comment:1 by ami_stuff, 7 years ago

Cc: ami_stuff@o2.pl added

comment:2 by ami_stuff, 6 years ago

there is gray12 pix_fmt in ffmpeg since some time ;)

https://lists.ffmpeg.org/pipermail/ffmpeg-cvslog/2016-November/102808.html

comment:3 by Carl Eugen Hoyos, 6 years ago

Yes, the reason is this very ticket;-)

comment:4 by Elon Musk, 4 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.