Opened 4 years ago

Closed 3 years ago

#4662 closed enhancement (fixed)

swscale support for Y416 as a pixel format

Reported by: rmk Owned by:
Priority: wish Component: swscale
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Currently Y416 is not supported as a pixel format. An example of where this is required is feeding the native Apple Prores 4444 codec with input data.

Change History (8)

comment:1 Changed 4 years ago by richardpl

Are there actual samples? I think mpc-hc supports Y416.

comment:2 Changed 4 years ago by compn

it might be hard for us developers to produce Y416 prores files, could you create a sample for us?

also full ffmpeg output would be nice for you to report.
many problems are due to using old/outdated or bad forks of ffmpeg.

comment:3 Changed 4 years ago by cehoyos

  • Resolution set to wontfix
  • Status changed from new to closed

From FFmpeg pov, yuv444p16 == Y416, no packed format will be added unless there is a usecase with a very good explanation.

comment:4 Changed 4 years ago by rmk

The reason is that it is not possible to create media buffers with libavcodec that can be fed to the Apple encoder. Libavcocec being a general purpose library I thought it is also a use case to use libavcodec in a heterogenous (i.e. non-ffmpeg-only) set-up. Is there a specific reason for not supporting this if someone is willing to implement it?

comment:5 Changed 4 years ago by cehoyos

  • Resolution wontfix deleted
  • Status changed from closed to reopened
  • Version changed from unspecified to git-master

I would expect that a patch won't be rejected as long as it is clean and sufficiently optimised.

Can you explain the issues you have with FFmpeg's encoder?

comment:6 Changed 4 years ago by cehoyos

How does Apple call the required colour space in its documentation?

comment:7 Changed 4 years ago by richardpl

kCVPixelFormatType_4444AYpCbCr16 = 'y416', /* Component Y'CbCrA 16-bit 4:4:4:4, ordered A Y' Cb Cr, full range alpha, video range Y'CbCr?, 16-bit little-endian samples. */

comment:8 Changed 3 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.