Opened 3 years ago

Closed 3 years ago

#4657 closed defect (fixed)

jpeg2000: unsupported marker 0xff5f

Reported by: ami_stuff Owned by:
Priority: normal Component: avcodec
Version: git-master Keywords: j2k
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

C:\>kdu_compress.exe -i test.bmp -o ff5f.jp2 -rate 1.0,0.5,0.1,0.03 Stiles={300,200} Corder=LRCP Porder:T1={0,0,2,10,10,LRCP} Porder:T1={0,0,4,10,10,PCRL}
Note:
    The default rate control policy for colour images employs visual (CSF)
    weighting factors.  To minimize MSE instead, specify `-no_weights'.

Generated 16 tile-part(s) for a total of 15 tile(s).
Code-stream bytes (excluding any file format) = 92,979 = 0.994094 bits/pel.
Layer bit-rates (possibly inexact if tiles are divided across tile-parts):
        0.030033, 0.099090, 0.500142, 0.994094
Layer thresholds:
        45466, 44551, 43327, 42651
Processed using the multi-threaded environment, with
    8 parallel threads of execution

this is example from kakadu documentation

    -- Tile 1 (the second tile) gets two tile-parts.  The first tile-part of
       tile 1 includes the first 2 layers (0.1 bits per sample) and has a
       layer progressive order (LRCP).  The second tile-part contains the
       final two quality layers and has a resolution-progressive order (RLCP).
       The first tile-part of every tile appears first, followed by the extra
       tile-part of tile 1 (interleaved tile-parts).  Interesting things happen
       when you truncate the code-stream to a bit-rate below 1.0 -- you
       should be able to guess.
C:\>ffmpeg -i ff5f.jp2 out.bmp
ffmpeg version N-73010-gbb3703a Copyright (c) 2000-2015 the FFmpeg developers
  built with gcc 4.9.2 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-av
isynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab
le-iconv --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --
enable-libdcadec --enable-libfreetype --enable-libgme --enable-libgsm --enable-l
ibilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enab
le-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --en
able-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --ena
ble-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc
 --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enabl
e-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-lzma --ena
ble-decklink --enable-zlib
  libavutil      54. 27.100 / 54. 27.100
  libavcodec     56. 41.100 / 56. 41.100
  libavformat    56. 37.100 / 56. 37.100
  libavdevice    56.  4.100 / 56.  4.100
  libavfilter     5. 17.100 /  5. 17.100
  libswscale      3.  1.101 /  3.  1.101
  libswresample   1.  2.100 /  1.  2.100
  libpostproc    53.  3.100 / 53.  3.100
[jpeg2000 @ 034b18e0] unsupported marker 0xFF5F at pos 0xEE9A
[jpeg2000 @ 034b18e0] unsupported marker 0xFF5F at pos 0x1509A
[jpeg2000 @ 034b18e0] End mismatch 1
[jpeg2000 @ 034b18e0] End mismatch 3
[jpeg2000 @ 034b18e0] End mismatch 1
[jpeg2000 @ 034b18e0] End mismatch 14
[jpeg2000 @ 034b18e0] End mismatch 4
[jpeg2000 @ 034b18e0] End mismatch 25
[jpeg2000 @ 034b18e0] End mismatch 19
[jpeg2000 @ 034b18e0] End mismatch 7
[jpeg2000 @ 034b18e0] End mismatch 12
[jpeg2000 @ 034b18e0] End mismatch 71
Input #0, j2k_pipe, from 'ff5f.jp2':
  Duration: N/A, bitrate: N/A
    Stream #0:0: Video: jpeg2000 (JPEG 2000 codestream restriction 0), rgb24, 99
9x749, 25 tbr, 25 tbn, 25 tbc
Output #0, image2, to 'out.bmp':
  Metadata:
    encoder         : Lavf56.37.100
    Stream #0:0: Video: bmp, bgr24, 999x749, q=2-31, 200 kb/s, 25 fps, 25 tbn, 2
5 tbc
    Metadata:
      encoder         : Lavc56.41.100 bmp
Stream mapping:
  Stream #0:0 -> #0:0 (jpeg2000 (native) -> bmp (native))
Press [q] to stop, [?] for help
[jpeg2000 @ 03cde020] unsupported marker 0xFF5F at pos 0xEE9A
[jpeg2000 @ 03cde020] unsupported marker 0xFF5F at pos 0x1509A
[jpeg2000 @ 03cde020] End mismatch 1
[jpeg2000 @ 03cde020] End mismatch 3
[jpeg2000 @ 03cde020] End mismatch 1
[jpeg2000 @ 03cde020] End mismatch 14
[jpeg2000 @ 03cde020] End mismatch 4
[jpeg2000 @ 03cde020] End mismatch 25
[jpeg2000 @ 03cde020] End mismatch 19
[jpeg2000 @ 03cde020] End mismatch 7
[jpeg2000 @ 03cde020] End mismatch 12
[jpeg2000 @ 03cde020] End mismatch 71
frame=    1 fps=0.0 q=0.0 Lsize=N/A time=00:00:00.04 bitrate=N/A
video:2194kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing
overhead: unknown

Attachments (1)

ff5f.jp2 (90.9 KB) - added by ami_stuff 3 years ago.

Download all attachments as: .zip

Change History (5)

Changed 3 years ago by ami_stuff

comment:1 follow-up: Changed 3 years ago by cehoyos

  • Component changed from undetermined to avcodec
  • Keywords j2k added
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

Could be a duplicate of ticket #2586.

Can you decode the file losslessly? It fails completely for me with ffmpeg -vcodec libopenjpeg -i ff5f.jp2

comment:2 in reply to: ↑ 1 Changed 3 years ago by ami_stuff

Replying to cehoyos:

Could be a duplicate of ticket #2586.

Can you decode the file losslessly? It fails completely for me with ffmpeg -vcodec libopenjpeg -i ff5f.jp2

It fails here as well.

comment:3 Changed 3 years ago by ami_stuff

and this sample is not lossless btw

Creversible=?

Whether or not it’s reversible. Set to yes for lossless compression, but not set for lossy compression (the suggested ones at OldMapsOnline)

https://github.com/DDMAL/diva.js/wiki/JPEG-2000-encoding-with-Kakadu

comment:4 Changed 3 years ago by michael

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.