Opened 5 years ago

Closed 5 years ago

#462 closed defect (needs_more_info)

Broken SSE instruction under MinGW (Windows)

Reported by: Gimli Owned by:
Priority: normal Component: avcodec
Version: git-master Keywords: sse
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no


ff_imdct_half_sse segfault with NULL pointer

siginfo: ExceptionCode?=0xc0000005, reading address 0x00000000

EAX=0x001a5cd4, EBX=0x000001fc, ECX=0x001a4cd4, EDX=0x3d201da4
ESP=0x3d05f650, EBP=0x001a9180, ESI=0xfffffe04, EDI=0x001a8980
EIP=0x65f7d7ea, EFLAGS=0x00210293

Register to memory mapping:

0x001a5cd4 is pointing to unknown location

0x000001fc is pointing to unknown location

0x001a4cd4 is pointing to unknown location

0x3d201da4 is pointing to unknown location

0x3d05f650 is pointing into the stack for thread: 0x3cc04400
"RTSP_CAMERA vivotek_fd8161.0: UNKNOWN" prio=2 tid=0x3cc04400 nid=0xb50 runnable [0x3d05f000]

java.lang.Thread.State: RUNNABLE

0x001a9180 is pointing to unknown location

0xfffffe04 is pointing to unknown location

0x001a8980 is pointing to unknown location

Top of Stack: (sp=0x3d05f650)
0x3d05f650: 001a8360 001a9180 001a8980 001a47c0
0x3d05f660: 660e4110 3d20c4c0 3d200100 65e01c35
0x3d05f670: 001a5cd4 001a4cd4 3d2015a4 36662728
0x3d05f680: 3cc04518 00000000 3d05f6c8 02509fc7
0x3d05f690: 3cc04518 697823db 0250a276 001a4cd4
0x3d05f6a0: 3d2025a4 3d2035a4 65ff1c90 660e3310
0x3d05f6b0: 3d05f6dc 36662d00 00000000 3d200060
0x3d05f6c0: 3d20c4c0 00000000 00000000 65e06c50

Instructions: (pc=0x65f7d7ea)
0x65f7d7da: 55 83 eb 04 31 f6 29 de 8b 6c 24 04 8b 7c 24 08
0x65f7d7ea: 0f 28 04 9a 0f 28 4c b2 f0 0f 28 d0 0f c6 c1 88

compilation params:
--disable-debug --disable-bsfs --disable-protocols --disable-devices --disable-muxers --disable-decoders --disable-encoders --disable-ffplay --disable-ffserver --disable-ffmpeg --disable-gray --disable-static --disable-filters --enable-shared --enable-decoder=h264 --enable-decoder=mpeg4 --enable-decoder=mjpeg --disable-zlib --disable-bzlib --disable-network --disable-parsers --disable-demuxers --enable-decoder=aac --enable-parser=aac --enable-filter=buffersink --enable-hwaccel=h264_dxva2 --enable-hwaccel=mpeg4_vaapi --enable-hwaccel=h264_vaapi --enable-vdpau

If you need any other specification please add note.

Change History (3)

comment:1 Changed 5 years ago by Gimli

with params --disable-sse everything seems to be OK, the same for mac OS X and UNIX systems

Version 0, edited 5 years ago by Gimli (next)

comment:2 Changed 5 years ago by cehoyos

Is the problem reproducible with ffmpeg (the application)?
If yes, please follow (closely), gdb works fine under windwos.

comment:3 Changed 5 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

Please re-open this ticket if more information is available.

Note: See TracTickets for help on using tickets.