Opened 3 years ago

Closed 3 years ago

#4593 closed defect (fixed)

Building ffmpeg with a libvpx installed with a custom prefix path fails

Reported by: exophoric Owned by:
Priority: normal Component: build system
Version: git-master Keywords: pkg-config libvpx
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

I'm trying to build ffmpeg with libvpx-1.4.0 under linux (tried on CentOS 6 and Ubuntu 12.04). Although, being without root access, I compiled and installed libvpx in a non-system location.

Reading ffmpeg's configure script, I saw that it doesn't use pkg-config to find the proper path of libvpx headers and libraries.

How to reproduce:

1) Configure, build and install libvpx using a custom --prefix location
2) Add the custom location of libvpx/lib/pkgconfig to PKG_CONFIG_PATH environment variable
2.5) Ensure that "pkg-config --libs vpx" reports the correct path
3) Launch ffmpeg's configure script using --enable-libvpx switch

How to workaround the problem:

I successfully built ffmpeg with libvpx-1.4.0 support by disabling the checks in the configure script (commenting out lines 5155 to 5160, as of 6fd15d6) and by adding the path to headers in CFLAGS of config.mak and libs in LDFLAGS. But that is probably a stupid idea.

How to possibly fix the problem:

I think that pkg-config could be used to find libvpx, just as it is used to find libx264. libvpx supports pkgconfig since v0.9.5 which was released in late 2010.

Change History (2)

comment:1 Changed 3 years ago by exophoric

I forgot to attach the error message obtained when you launch the configure script:

exophoric@somecomputer:~/ffmpeg$ ./configure --enable-libvpx
ERROR: libvpx decoder version must be >=0.9.1

If you think configure made a mistake, make sure you are using the latest
version from Git.  If the latest version fails, report the problem to the
ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.log" produced by configure as this will help
solve the problem.

comment:2 Changed 3 years ago by jamrial

  • Component changed from avformat to build system
  • Resolution set to fixed
  • Status changed from new to closed

pkg-config is now used starting with commit 1e7008675b2d930955b0295808ef208d92e5639d

Note: See TracTickets for help on using tickets.