Opened 4 years ago

Closed 4 years ago

#4576 closed enhancement (wontfix)

Add wrapper for faad2

Reported by: Aleksoid1978 Owned by:
Priority: normal Component: avcodec
Version: unspecified Keywords: aac latm
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Currently there are problems with decoding some AAC LATM stream, especially multi-channel. While decoding we have many error such "ChannelElement? x.x missing"

Maybe add wrapper for library faad2 to allow use it for decoding aac/aac_latm streams.

Change History (11)

comment:1 in reply to: ↑ description Changed 4 years ago by cehoyos

  • Resolution set to wontfix
  • Status changed from new to closed

Replying to Aleksoid1978:

Currently there are problems with decoding some AAC LATM stream, especially multi-channel. While decoding we have many error such "ChannelElement? x.x missing"

Which ticket are you thinking of?

Maybe add wrapper for library faad2 to allow use it for decoding aac/aac_latm streams.

This is very unlikely given that we removed the wrapper some time ago (and it would not help for latm given that we chose a different infrastructure for latm than vlc).

comment:2 follow-up: Changed 4 years ago by Aleksoid1978

There are many tickets. One of this - https://trac.ffmpeg.org/ticket/4544

Also - i have some samples with AAC LATM(mpeg-ts format), that give the same error.

Last edited 4 years ago by Aleksoid1978 (previous) (diff)

comment:3 Changed 4 years ago by Aleksoid1978

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:4 in reply to: ↑ 2 Changed 4 years ago by cehoyos

Replying to Aleksoid1978:

There are many tickets. One of this - https://trac.ffmpeg.org/ticket/4544

Is there really another ticket?

Also - i have some samples with AAC LATM(mpeg-ts format), that give the same error.

Please provide such samples.

And please remember that the faad wrapper - that will hopefully not be added - would not fix your issue: faad in FFmpeg would not be able to decode latm (latm was implemented differently in vlc, the faad wrapper can be used for latm in vlc).

comment:5 Changed 4 years ago by Aleksoid1978

Here another samples:
https://yadi.sk/i/cBPlLgqgguszf
https://yadi.sk/i/DlLlZ6_1guuho
https://yadi.sk/i/9gFnA5bpguui6
broken playback only 5.1 aac latm streams, stereo - fine.

Last edited 4 years ago by Aleksoid1978 (previous) (diff)

comment:6 Changed 4 years ago by Aleksoid1978

Also - currently broken decode some aac streams. While decode see error like "channel element x.x is not allocated"

sample:
https://yadi.sk/i/X7wxjqufgutre
https://yadi.sk/i/GAFBFvXwgutsH

comment:7 Changed 4 years ago by Aleksoid1978

All this sample play fine in latest VLC

Version 0, edited 4 years ago by Aleksoid1978 (next)

comment:8 Changed 4 years ago by Aleksoid1978

Any new information ??

comment:9 Changed 4 years ago by cehoyos

As said, it is very unlikely that a faad2 wrapper will be added, and if it were, it would not fix your issues with latm.

comment:10 Changed 4 years ago by Aleksoid1978

So - what about aac error, what's wrong with aac sample ??

comment:11 Changed 4 years ago by cehoyos

  • Resolution set to wontfix
  • Status changed from reopened to closed

aac_broken.mp4

This is ticket #1614.

aac_not_detected.ts

This is the sample from ticket #3408.

clip1_audiox3_(aac5.1_aac2.0_eac3).mts
clip2_audiox2_(aac5.1_aac2.0).mts
globo hd 20120424 champions league paulonline.ts

This looks like ticket #4544. All three files play fine with vlc --codec ffmpeg here, indicating a parser issue iiuc.

Note: See TracTickets for help on using tickets.