Opened 4 years ago

Closed 4 years ago

#4568 closed defect (fixed)

x11grab cannot be at the same resolution as the screen

Reported by: ingolfured Owned by:
Priority: important Component: avdevice
Version: Keywords: xcb regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:

% ffmpeg -f x11grab -s `xdpyinfo  | grep 'dimensions:'|awk '{print $2}'` -i $DISPLAY  -c:v libx264 fun.mkv
ffmpeg version 2.6.3
 built with gcc 4.9.2 (GCC) 20150304 (prerelease)
  configuration: --prefix=/usr --disable-debug --disable-static --disable-stripping --enable-avisynth --enable-avresample --enable-fontconfig --enable-gnutls --enable-gpl --enable-libass --enable-libbluray --enable-libfreetype --enable-libfribidi --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopencore_amrnb --enable-libopencore_amrwb --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-libschroedinger --enable-libspeex --enable-libssh --enable-libtheora --enable-libv4l2 --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libx265 --enable-libxvid --enable-shared --enable-version3 --enable-x11grab
  libavutil      54. 20.100 / 54. 20.100
  libavcodec     56. 26.100 / 56. 26.100
  libavformat    56. 25.101 / 56. 25.101
  libavdevice    56.  4.100 / 56.  4.100
  libavfilter     5. 11.102 /  5. 11.102
  libavresample   2.  1.  0 /  2.  1.  0
  libswscale      3.  1.101 /  3.  1.101
  libswresample   1.  1.100 /  1.  1.100
  libpostproc    53.  3.100 / 53.  3.100

I get the following error message Capture area 1920x1080 at position 0.0 outside the screen size 1920x1080

Change History (1)

comment:1 Changed 4 years ago by cehoyos

  • Component changed from ffmpeg to avdevice
  • Keywords xcb regression added; x11grab resolution removed
  • Priority changed from normal to important
  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from new to closed
  • Version git-master deleted

Regression since 9ccaeff67a3b0f75f7f25c39c5d373b560dcfb19 - will be fixed in 2.6.4.

For future tickets: Please always provide your failing command line together with the complete, uncut console output.

Note: See TracTickets for help on using tickets.