Opened 5 years ago

Closed 5 years ago

#444 closed defect (invalid)

x264 rev. 2074 - part of image jumping with some presets and strange bitrate dependance

Reported by: Dimon Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no


I have almost fully static 1920x1080p 25fps scene: dark bottom with some tree branches shaking within no more then 10 pixels and slow clouds passing by. In 30 sec of the whole scene there are couple of ~2 sec chunks, where bottom of the image begin to jump with ~0.2 sec period, up and down with visual amplitude 8-16 pixels. This happens only with "--preset" settings slow, slower and "harder". More "light" presets work pretty. Initial file is .mts, decoded through ffdshow/AviSynth. The command line is:

x264 --preset slower -b 6 -r 8 --crf 18 -o file.mkv file.avs

Players were Classic Media Player and VideLan? VLC, showing the same.

Varying -b and -r parameters doesn't help, so lack of memory for decoding is not very probable reason (Core Duo 2.8 GHz, 2GB RAM)

Also, in this and close situation, with only slooowly moving and transforming clouds in the frame: veryfast, faster, fast, normal presets sequence gives growing bitrate! When visualising motion vectors in ffmpeg plugin, more "hard" preset shows longer vectors.

Change History (3)

comment:1 Changed 5 years ago by cehoyos

Please explain if there is a problem with FFmpeg and if yes what the problem is.
(x264 is a different, independent application.)

comment:2 Changed 5 years ago by Dimon

No ,actually FFmpeg itself doesn't cause any problem.

I'm here from VideoLAN page. "BUGS" in the bottom

If I am at the wrong address please delete the ticket.

comment:3 Changed 5 years ago by cehoyos

  • Keywords mts x264 block jumping removed
  • Resolution set to invalid
  • Status changed from new to closed

First read the FFmpeg bug report guidelines.
Then report your bug to

Note: See TracTickets for help on using tickets.