Opened 4 years ago

Closed 4 years ago

#4324 closed defect (fixed)

No startcode Found, muxing to mpegts

Reported by: BlackDream Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: mpegts h264
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

ffmpeg -i test.ts -c copy -f mpegts /tmp/test.ts
ffmpeg version N-69131-gab161bf Copyright (c) 2000-2015 the FFmpeg developers
  built on Jan 17 2015 16:14:31 with gcc 4.8 (Ubuntu 4.8.2-19ubuntu1)
  configuration: --prefix=/root/ffmpeg/target --extra-cflags='-I/root/ffmpeg/target/include -static' --extra-ldflags='-L/root/ffmpeg/target/lib -lm -static' --disable-debug --disable-shared --enable-static --extra-cflags=--static --disable-ffplay --disable-ffserver --disable-doc --enable-openssl --enable-gpl --enable-pthreads --enable-postproc --enable-libass --enable-gray --enable-runtime-cpudetect --enable-libfaac --enable-gnutls --enable-libmp3lame --enable-libopus --enable-libtheora --enable-libvorbis --enable-libx264 --enable-libxvid --enable-bzlib --enable-zlib --enable-nonfree --enable-version3 --enable-libvpx --enable-libxavs --disable-devices --enable-librtmp --extra-libs='-lrtmp -lnettle -lhogweed -lgmp -lssl -lcrypto -lz -lc -ldl'
  libavutil      54. 17.100 / 54. 17.100
  libavcodec     56. 20.100 / 56. 20.100
  libavformat    56. 19.100 / 56. 19.100
  libavdevice    56.  4.100 / 56.  4.100
  libavfilter     5.  8.100 /  5.  8.100
  libswscale      3.  1.101 /  3.  1.101
  libswresample   1.  1.100 /  1.  1.100
  libpostproc    53.  3.100 / 53.  3.100
[h264 @ 0x38a2ae0] non-existing PPS 0 referenced
    Last message repeated 1 times
[h264 @ 0x38a2ae0] decode_slice_header error
[h264 @ 0x38a2ae0] no frame!
[h264 @ 0x38a2ae0] non-existing PPS 0 referenced
    Last message repeated 1 times
[h264 @ 0x38a2ae0] decode_slice_header error
[h264 @ 0x38a2ae0] no frame!
[NULL @ 0x38a41e0] start time for stream 2 is not set in estimate_timings_from_pts
Input #0, mpegts, from 'test.ts':
  Duration: 00:00:10.06, start: 91097.537178, bitrate: 878 kb/s
  Program 1
    Stream #0:0[0x100]: Video: h264 (Main) ([27][0][0][0] / 0x001B), yuv420p(tv), 640x360 [SAR 1:1 DAR 16:9], 25 fps, 25 tbr, 90k tbn, 50 tbc
    Stream #0:1[0x101]: Audio: aac (LC) ([15][0][0][0] / 0x000F), 44100 Hz, stereo, fltp, 124 kb/s
    Stream #0:2[0x102]: Data: timed_id3 (ID3  / 0x20334449)
File '/tmp/test.ts' already exists. Overwrite ? [y/N] y
Output #0, mpegts, to '/tmp/test.ts':
  Metadata:
    encoder         : Lavf56.19.100
    Stream #0:0: Video: h264 ([27][0][0][0] / 0x001B), yuv420p, 640x360 [SAR 1:1 DAR 16:9], q=2-31, 25 fps, 25 tbr, 90k tbn, 25 tbc
    Stream #0:1: Audio: aac ([15][0][0][0] / 0x000F), 44100 Hz, stereo, 124 kb/s
Stream mapping:
  Stream #0:0 -> #0:0 (copy)
  Stream #0:1 -> #0:1 (copy)
Press [q] to stop, [?] for help
[mpegts @ 0x38a5ea0] H.264 bitstream malformed, no startcode found, use the video bitstream filter 'h264_mp4toannexb' to fix it ('-bsf:v h264_mp4toannexb' option with ffmpeg)
av_interleaved_write_frame(): Invalid data found when processing input
frame=    1 fps=0.0 q=-1.0 Lsize=       3kB time=00:00:00.13 bitrate= 172.7kbits/s
video:18kB audio:2kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: unknown
Conversion failed!

The input source is already an mpegts stream, as well as the output. I can't make this stream to work no matter what command i will use.

Attachments (1)

test.ts (1.1 MB) - added by BlackDream 4 years ago.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by BlackDream

comment:1 Changed 4 years ago by cehoyos

  • Keywords mpegts h264 added

An update of http://thread.gmane.org/gmane.comp.video.ffmpeg.devel/162216 probably fixes the issue, I suspect your input stream is invalid.

comment:2 Changed 4 years ago by BlackDream

The above patch didn't fix the issue :-(

comment:3 Changed 4 years ago by cehoyos

Works fine here with the patch...

comment:4 Changed 4 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from new to closed

Duplicate of ticket #2220, fixed in 56ffde3f619076650bdc6003cc683cf2f563463f

Note: See TracTickets for help on using tickets.