Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#4288 closed defect (invalid)

libfdk_aac - channel 3 is corrupt

Reported by: amnonbb Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:

ffmpeg -i test.wav -c:a libfdk_aac -ac 8 -f flv test.flv
ffmpeg -y -i test.wav -map_channel 0.0.3 ok_channel.wav
ffmpeg -y -i test.flv -map_channel 0.0.3 defect_channel.wav

http://ffmpeg.itgb.net/test.wav
http://ffmpeg.itgb.net/test.flv
http://ffmpeg.itgb.net/ok_channel.wav
http://ffmpeg.itgb.net/defect_chennel.wav

Patches should be submitted to the ffmpeg-devel mailing list and not this bug tracker.

Change History (5)

comment:1 Changed 3 years ago by amnonbb

  • Version changed from 2.5.2 to git-master

comment:2 Changed 3 years ago by Cigaes

Channel 3 is the subwoofer, the behaviour you observe is normal.

comment:3 Changed 3 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed

The input file reports one channel as LFE, this is not correct.

For future tickets, please don't forget to provide the command line that allows to reproduce the issue together with the complete, uncut console output.

comment:4 Changed 3 years ago by amnonbb

The input file is 7.1

‘7.1’
FL+FR+FC+LFE+BL+BR+SL+SR

‘7.1(wide)’
FL+FR+FC+LFE+BL+BR+FLC+FRC

‘7.1(wide-side)’
FL+FR+FC+LFE+FLC+FRC+SL+SR

So one channel is LFE.
What exactly not correct?

comment:5 Changed 3 years ago by cehoyos

As you reported, the channel is not actually LFE, but an independent channel. Since the input file reports the channel as LFE, it is correct to encode it as LFE. LFE-encoded channels sound bad if they are not really LFE.

Note: See TracTickets for help on using tickets.