Opened 3 years ago

Closed 3 years ago

#4199 closed defect (fixed)

When omitting '--shlibdir=' for configure, SHLIBDIR expands to $DESTDIR$DESTDIR...

Reported by: friedinsugar Owned by:
Priority: important Component: build system
Version: git-master Keywords: regression
Cc: michael Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
In the generated config.mak,
SHLIBDIR expands to
$(DESTDIR)$(DESTDIR)...

How to reproduce:
Run configure without '--shlibdir='

Possible cause of bug:
the following line in the 'configure' file:
shlibdir_default='${LIBDIR}'

should be instead
shlibdir_default='${libdir_default}'

but I need a second opinion.

Change History (8)

comment:1 Changed 3 years ago by cehoyos

  • Keywords regression added

How can I reproduce this?
If I run ./configure (without --shlibdir), SHLIBDIR expands to /usr/local/lib which is what I expected.

comment:2 Changed 3 years ago by iive

$DESTDIR is used by packaging to redirect the installation to somewhere else than the root of the filesystem.
You usually do something like make install DESTDIR=/tmp/package .

I think the fix should be:
shlibdir_default='${libdir}'

as we have:
LIBDIR=\$(DESTDIR)$libdir
SHLIBDIR=\$(DESTDIR)$shlibdir

comment:3 Changed 3 years ago by cehoyos

  • Reproduced by developer set
  • Status changed from new to open

comment:5 Changed 3 years ago by michael

  • Cc michael added

comment:6 follow-up: Changed 3 years ago by electropura

By changing shlibdir_default to:
shlibdir_default='${prefix}/lib'
DESTDIR seems to work as intended.

comment:7 in reply to: ↑ 6 Changed 3 years ago by michael

Replying to electropura:

By changing shlibdir_default to:
shlibdir_default='${prefix}/lib'
DESTDIR seems to work as intended.

This would break ticket 4183

comment:8 Changed 3 years ago by michael

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.