Opened 4 years ago

Last modified 4 years ago

#4177 reopened license violation

Digimetrics Hydra Player violates the GPL

Reported by: kierank Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: eric@digi-metrics.com, HallEstillLaw Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Asked for an evaluation copy of this product and has FFmpeg dlls containing --enable-gpl --enable-version3 in it.

Attachments (3)

Hydra_EULA (21.7 KB) - added by kierank 4 years ago.
EULA from 4.0.293
EULA - Aurora (2014-12-15).pdf (104.4 KB) - added by ericmcarson 4 years ago.
Aurora 5.1.277.0 EULA
EULA - Hydra (2014-12-15).pdf (102.9 KB) - added by ericmcarson 4 years ago.
Hydra 4.0.296.0 EULA

Download all attachments as: .zip

Change History (24)

comment:1 Changed 4 years ago by kierank

Also the same violation with their Aurora software.

comment:2 Changed 4 years ago by ericmcarson

This was introduced by a new developer at Digimetrics who downloaded a precompiled version of FFMPEG when he ported some 64-bit code rather than using the FFMPEG build environment here to make the LGPL builds. This issue will be resolved in both Aurora & Hydra today, 10 December, 2014. I will post new build numbers here once it is fixed.

Previous builds of Aurora & Hydra have already been taken down from distribution while this is resolved.

Eric Carson
CTO & Founder, Digimetrics

comment:3 Changed 4 years ago by ericmcarson

This is now resolved in Aurora (5.1.275.0) and Hydra (4.0.293). FFMPEG in both now has the GPL and enable v3 options compiled out. As always, Digimetrics distributes the source of the LGPL projects we use without modification or static linking from the same FTP location as our product downloads, and we also post required notices in our Help, About boxes.

This should resolve this particular issue.

Eric Carson
CTO & Founder, Digimetrics

comment:4 Changed 4 years ago by ericmcarson

  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 4 years ago by cehoyos

  • Resolution fixed deleted
  • Status changed from closed to reopened

Please point us to your new installer.

Changed 4 years ago by kierank

EULA from 4.0.293

comment:6 Changed 4 years ago by cehoyos

  • Reproduced by developer set
  • Status changed from reopened to open

comment:7 Changed 4 years ago by ericmcarson

You have access to the new installers, as you already have the EULA from the new builds. If you have an issue with the EULA, please inform specifically what items you feel conflict with LGPL v2.1.

comment:8 Changed 4 years ago by ericmcarson

  • Cc eric@digi-metrics.com added

comment:9 in reply to: ↑ description Changed 4 years ago by ericmcarson

Replying to kierank:

Asked for an evaluation copy of this product and has FFmpeg dlls containing --enable-gpl --enable-version3 in it.

These options are no longer in either Hydra or Aurora as 10 December, 2014.

comment:10 Changed 4 years ago by cehoyos

Yes, you are correct that the EULA does not conform to the LGPL. Please read our legal page for the checklist.

comment:11 Changed 4 years ago by ericmcarson

Digimetrics fully complies with the LGPL with the current builds of Aurora & Hydra. We have confirmed this with our legal counsel.

The FFmpeg website states that your checklist has additional requirements not listed in the LGPL. “The following is a checklist for LGPL compliance when linking against the FFmpeg libraries. It is not the only way to comply with the license, but we think it is the easiest. There are also a few items that are not really related to LGPL compliance but are good ideas anyway.” https://www.ffmpeg.org/legal.html.

We appreciate you think the checklist is a good idea, but Digimetrics has licensed the LGPL, not the checklist, and has been advised by our legal counsel that we do not need to comply with the checklist except to the extent that the checklist requires items that specifically appear in the LGPL. If there is a particular section of the LGPL that you believe is violated, please identify it so we can know the basis for your complaint.

Finally, even though the LGPL does not mention EULAs, in the spirit of cooperation and an effort to resolve this matter, the EULAs for the Digimetrics software Aurora and Hydra have been updated to separately identify the open source components of the Digimetrics software including the FFmpeg libraries, and state that these can be used subject to the rights of the owners of the open source software. The emails that Digimetrics sends out with a hyperlink to our FTP server for file access have been similarly amended, as have the Help, About sections of our software. While these steps were not necessary to comply with the LGPL, as you said, “these are good ideas anyway.”

Updated EULAs for both Aurora & Hydra are attached. We will consider this issue resolved unless you have specific EULA sections you can point to being non-compliant with the LGPL.

Eric Carson
CTO & Founder, Digimetrics

Changed 4 years ago by ericmcarson

Aurora 5.1.277.0 EULA

Changed 4 years ago by ericmcarson

Hydra 4.0.296.0 EULA

comment:12 Changed 4 years ago by ericmcarson

  • Resolution set to fixed
  • Status changed from open to closed

comment:13 Changed 4 years ago by cehoyos

  • Resolution fixed deleted
  • Status changed from closed to reopened

Please allow me to express my deepest regrets that we are not able anymore to go after license violators like Digimetrics.

comment:14 Changed 4 years ago by ericmcarson

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:15 Changed 4 years ago by cehoyos

  • Resolution fixed deleted
  • Status changed from closed to reopened

Please do not randomly close tickets.
Please go through our compliance list again, no need to pay your legal council.

comment:16 follow-up: Changed 4 years ago by ericmcarson

Cehoyos, I am not randomly closing tickets. I am marking the issue as fixed, just as it is resolved. Your ticket reads that Digimetrics' software violates the GPL, which it does not in the current distributed form. Additionally, Digimetrics' software is not violating the LGPL. Your compliance checklist contains items that are not required by the LGPL. Please see my previous comment:

We appreciate you think the checklist is a good idea, but Digimetrics has licensed the LGPL, not the checklist, and has been advised by our legal counsel that we do not need to comply with the checklist except to the extent that the checklist requires items that specifically appear in the LGPL. If there is a particular section of the LGPL that you believe is violated, please identify it so we can know the basis for your complaint.

Eric Carson
CTO & Founder, Digimetrics

comment:17 follow-up: Changed 4 years ago by HallEstillLaw

My name is Randy McCarthy?, I am an intellectual property attorney with Hall Estill (Rmccarthy@hallestill.com) and we represent Digimetrics. Please ask your legal counsel to contact me immediately regarding the basis for continued accusations against my client of breach of the terms of the LGPL license agreement. Accusations of breach are a serious matter with legal implications for all parties involved.

comment:18 in reply to: ↑ 17 Changed 4 years ago by cehoyos

Replying to HallEstillLaw:

My name is Randy McCarthy?, I am an intellectual property attorney with Hall Estill (Rmccarthy@hallestill.com) and we represent Digimetrics. Please ask your legal counsel to contact me immediately regarding the basis for continued accusations against my client of breach of the terms of the LGPL license agreement. Accusations of breach are a serious matter with legal implications for all parties involved.

Sorry, I am not a native speaker: Are you threatening me or is this just a misunderstanding on my side?

comment:19 in reply to: ↑ 16 Changed 4 years ago by cehoyos

  • Cc HallEstillLaw added

Replying to ericmcarson:

Cehoyos

Not necessarily related: You will find my name immediately in git and many details about me quickly on the internet.

I am not randomly closing tickets. I am marking the issue as fixed, just as it is resolved.

Since there are only two relevant states on this bug tracker to make our lives easier (open and closed), please understand that it is our responsibility to verify that a license violation like yours is resolved.

Your ticket reads that Digimetrics' software violates the GPL, which it does not in the current distributed form.

I consider this hairsplitting sentence impertinent, please also read paragraph 8 of the LGPLv2 (paragraph 4 of the GPLv2) in this context.

While I try to calm down, please remove paragraph 4 of your EULA (it is not compatible with the LGPL) and provide a link to the download page of your installer: This is a precondition to get your license reinstated because it will allow us to check future installers from your company.

comment:20 follow-up: Changed 4 years ago by gjdfgh

Since this company already published a product with the license violation included, doesn't this mean they are required to hand over the full source code of the product to anyone who requests it?

Lawyer guy with the clever job of being paid for threatening an open source project for protecting its rights from evil companies which don't give back anything, what do you say?

comment:21 in reply to: ↑ 20 Changed 4 years ago by cehoyos

Replying to gjdfgh:

Since this company already published a product with the license violation included, doesn't this mean they are required to hand over the full source code of the product to anyone who requests it?

From a (continental) European point-of-view:
No, there is no indication that Digimetrics ever wanted to comply with the GPL, so there is no contract between FFmpeg and Digimetrics under the terms of the GPL so FFmpeg can make no claims based on the GPL.

The situation in the US may or may not be different.

IANAL.

Note: See TracTickets for help on using tickets.