Opened 3 years ago

Closed 3 years ago

#4172 closed defect (duplicate)

https stream error (does not contain any stream)

Reported by: Einguste Owned by:
Priority: important Component: avformat
Version: git-master Keywords: hls crypto regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:

% ffmpeg.exe -y -i https://nhk-vh.akamaihd.net/i/gogaku-stream/mp4/14-ebn-4232-5
48.mp4/master.m3u8 -b:a 64k -id3v2_version 3 2014_12_02.mp3
ffmpeg version N-68271-geb74839 Copyright (c) 2000-2014 the FFmpeg developers
  built on Dec  6 2014 22:31:47 with gcc 4.9.2 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libfreetype --enable-libgme --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-decklink --enable-zlib
  libavutil      54. 15.100 / 54. 15.100
  libavcodec     56. 14.100 / 56. 14.100
  libavformat    56. 15.102 / 56. 15.102
  libavdevice    56.  3.100 / 56.  3.100
  libavfilter     5.  2.103 /  5.  2.103
  libswscale      3.  1.101 /  3.  1.101
  libswresample   1.  1.100 /  1.  1.100
  libpostproc    53.  3.100 / 53.  3.100
Splitting the commandline.
Reading option '-v' ... matched as option 'v' (set logging level) with argument '9'.
Reading option '-loglevel' ... matched as option 'loglevel' (set logging level) with argument '99'.
Reading option '-y' ... matched as option 'y' (overwrite output files) with argument '1'.
Reading option '-i' ... matched as input file with argument 'https://nhk-vh.akamaihd.net/i/gogaku-stream/mp4/14-ebn-4232-548.mp4/master.m3u8'.
Reading option '-b:a' ... matched as option 'b' (video bitrate (please use -b:v)) with argument '64k'.
Reading option '-id3v2_version' ... matched as AVOption 'id3v2_version' with argument '3'.
Reading option '-t' ... matched as option 't' (record or transcode "duration" seconds of audio/video) with argument '1'.
Reading option '2014_12_02.mp3' ... matched as output file.
Finished splitting the commandline.
Parsing a group of options: global .
Applying option v (set logging level) with argument 9.
Applying option y (overwrite output files) with argument 1.
Successfully parsed a group of options.
Parsing a group of options: input file https://nhk-vh.akamaihd.net/i/gogaku-stream/mp4/14-ebn-4232-548.mp4/master.m3u8.
Successfully parsed a group of options.
Opening an input file: https://nhk-vh.akamaihd.net/i/gogaku-stream/mp4/14-ebn-4232-548.mp4/master.m3u8.
[https @ 0000000000305560] request: GET /i/gogaku-stream/mp4/14-ebn-4232-548.mp4/master.m3u8 HTTP/1.1

User-Agent: Lavf/56.15.102

Accept: */*

Range: bytes=0-

Connection: close

Host: nhk-vh.akamaihd.net

Icy-MetaData: 1




[https @ 0000000000305560] header='HTTP/1.1 206 Partial Content'
[https @ 0000000000305560] http_code=206
[https @ 0000000000305560] header='Server: AkamaiGHost'
[https @ 0000000000305560] header='Mime-Version: 1.0'
[https @ 0000000000305560] header='Content-Type: application/vnd.apple.mpegurl'
[https @ 0000000000305560] header='Pragma: no-cache'
[https @ 0000000000305560] header='Cache-Control: no-store'
[https @ 0000000000305560] header='Expires: Tue, 09 Dec 2014 16:19:55 GMT'
[https @ 0000000000305560] header='Date: Tue, 09 Dec 2014 16:19:55 GMT'
[https @ 0000000000305560] header='Content-Range: bytes 0-252/253'
[https @ 0000000000305560] header='Content-Length: 253'
[https @ 0000000000305560] header='Connection: close'
[https @ 0000000000305560] header='Access-Control-Allow-Headers: *'
[https @ 0000000000305560] header='Access-Control-Expose-Headers: *'
[https @ 0000000000305560] header='Access-Control-Allow-Methods: GET, HEAD, OPTIONS'
[https @ 0000000000305560] header='Access-Control-Allow-Origin: *'
[https @ 0000000000305560] header='Set-Cookie: _alid_=IDW94dJr76srIAFKybQdIg==; path=/i/gogaku-stream/mp4/14-ebn-4232-548.mp4/; domain=nhk-vh.akamaihd.net'
[https @ 0000000000305560] header=''
[hls,applehttp @ 0000000000304de0] Format hls,applehttp probed with size=2048 and score=100
[https @ 0000000000317220] request: GET /i/gogaku-stream/mp4/14-ebn-4232-548.mp4/index_0_a.m3u8?null=&id=AgDcZrSodpvmRCshh1QnsiTNFGuGoTDvSkuiOcNr7NfLJqj%2fmCvaI4nVLxffebgrywU0ncQELPK1xw%3d%3d HTTP/1.1

User-Agent: Lavf/56.15.102

Accept: */*

Connection: close

Host: nhk-vh.akamaihd.net

Cookie: _alid_=IDW94dJr76srIAFKybQdIg==

Icy-MetaData: 1

<snip>

[http @ 0000000005a20360] header='HTTP/1.1 200 OK'
[http @ 0000000005a20360] http_code=200
[http @ 0000000005a20360] header='Server: AkamaiGHost'
[http @ 0000000005a20360] header='Mime-Version: 1.0'
[http @ 0000000005a20360] header='Content-Type: video/MP2T'
[http @ 0000000005a20360] header='Content-Length: 66560'
[http @ 0000000005a20360] header='Pragma: no-cache'
[http @ 0000000005a20360] header='Cache-Control: no-store'
[http @ 0000000005a20360] header='Expires: Tue, 09 Dec 2014 16:20:01 GMT'
[http @ 0000000005a20360] header='Date: Tue, 09 Dec 2014 16:20:01 GMT'
[http @ 0000000005a20360] header='Connection: close'
[http @ 0000000005a20360] header='Access-Control-Allow-Headers: *'
[http @ 0000000005a20360] header='Access-Control-Expose-Headers: *'
[http @ 0000000005a20360] header='Access-Control-Allow-Methods: GET, HEAD, OPTIONS'
[http @ 0000000005a20360] header='Access-Control-Allow-Origin: *'
[http @ 0000000005a20360] header='Set-Cookie: _alid_=PXHWJ0kk2u7IT85/kUWmyg==; path=/i/gogaku-stream/mp4/14-ebn-4232-548.mp4/; domain=nhk-vh.akamaihd.net'
[http @ 0000000005a20360] header=''
[mpegts @ 000000000594baa0] Unable to seek back to the start
[mpegts @ 000000000594baa0] Before avformat_find_stream_info() pos: 5014336 bytes read:5015944 seeks:0
[mpegts @ 000000000594baa0] All info found
[mpegts @ 000000000594baa0] After avformat_find_stream_info() pos: 5014336 bytes read:5015944 seeks:0 frames:0
[hls,applehttp @ 0000000000304de0] Before avformat_find_stream_info() pos: 253 bytes read:253 seeks:0
[hls,applehttp @ 0000000000304de0] All info found
[hls,applehttp @ 0000000000304de0] After avformat_find_stream_info() pos: 253 bytes read:253 seeks:0 frames:0
Input #0, hls,applehttp, from 'https://nhk-vh.akamaihd.net/i/gogaku-stream/mp4/14-ebn-4232-548.mp4/master.m3u8':
  Duration: 00:15:00.86, bitrate: 0 kb/s
  Program 0 
    Metadata:
      variant_bitrate : 46000
Successfully opened the file.
Parsing a group of options: output file 2014_12_02.mp3.
Applying option b:a (video bitrate (please use -b:v)) with argument 64k.
Applying option t (record or transcode "duration" seconds of audio/video) with argument 1.
Successfully parsed a group of options.
Opening an output file: 2014_12_02.mp3.
Codec AVOption b (set bitrate (in bits/s)) specified for output file #0 (2014_12_02.mp3) has not been used for any stream. The most likely reason is either wrong type (e.g. a video option with no video streams) or that it is a private option of some encoder which was not actually used for any stream.
Successfully opened the file.
Output #0, mp3, to '2014_12_02.mp3':
Output file #0 does not contain any stream
[AVIOContext @ 0000000005a1bc20] Statistics: 0 seeks, 0 writeouts
[AVIOContext @ 0000000000316fc0] Statistics: 253 bytes read, 0 seeks
ffmpeg.exe -y -i https://nhk-vh.akamaihd.net/i/gogaku-stream/mp4/14-ebn-4232-5
48.mp4/master.m3u8 -b:a 64k -id3v2_version 3 2014_12_02.mp3
ffmpeg version 2.4.4 Copyright (c) 2000-2014 the FFmpeg developers
  built on Dec  7 2014 04:56:46 with gcc 4.9.1 (GCC)
  configuration: --enable-gpl --enable-version3 --enable-avisynth --enable-fontconfig --enable-frei0r --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libcaca --enable-libcdio --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libvidstab --enable-libwavpack --enable-libx264 --enable-libx265 --enable-libxvid --enable-libilbc --enable-libxavs --enable-opengl --enable-libwebp --enable-avresample --enable-w32threads --extra-ldflags=-static --extra-cflags='-march=i686 -mtune=generic -mfpmath=sse -msse' --optflags='-O2 -finline-functions'
  libavutil      54.  7.100 / 54.  7.100
  libavcodec     56.  1.100 / 56.  1.100
  libavformat    56.  4.101 / 56.  4.101
  libavdevice    56.  0.100 / 56.  0.100
  libavfilter     5.  1.100 /  5.  1.100
  libavresample   2.  1.  0 /  2.  1.  0
  libswscale      3.  0.100 /  3.  0.100
  libswresample   1.  1.100 /  1.  1.100
  libpostproc    53.  0.100 / 53.  0.100
Input #0, hls,applehttp, from 'https://nhk-vh.akamaihd.net/i/gogaku-stream/mp4/14-ebn-4232-548.mp4/master.m3u8':
  Duration: 00:15:00.86, start: 0.100667, bitrate: 0 kb/s
  Program 0 
    Metadata:
      variant_bitrate : 46000
    Stream #0:0: Audio: aac ([15][0][0][0] / 0x000F), 24000 Hz, stereo, fltp, 43 kb/s
    Metadata:
      variant_bitrate : 46000
    Stream #0:1: Data: timed_id3 (ID3  / 0x20334449)
    Metadata:
      variant_bitrate : 46000
Output #0, mp3, to '2014_12_02.mp3':
  Metadata:
    TSSE            : Lavf56.4.101
    Stream #0:0: Audio: mp3 (libmp3lame), 24000 Hz, stereo, fltp, 64 kb/s
    Metadata:
      variant_bitrate : 46000
      encoder         : Lavc56.1.100 libmp3lame
Stream mapping:
  Stream #0:0 -> #0:0 (aac (native) -> mp3 (libmp3lame))
Press [q] to stop, [?] for help
size=     195kB time=00:00:24.84 bitrate=  64.2kbits/s    
size=     391kB time=00:00:49.96 bitrate=  64.1kbits/s    
size=     565kB time=00:01:12.26 bitrate=  64.1kbits/s    
size=     725kB time=00:01:32.76 bitrate=  64.1kbits/s    
size=     905kB time=00:01:55.80 bitrate=  64.0kbits/s    
size=    1076kB time=00:02:17.64 bitrate=  64.0kbits/s    
size=    1250kB time=00:02:39.91 bitrate=  64.0kbits/s    
size=    1407kB time=00:02:59.97 bitrate=  64.0kbits/s    
size=    1563kB time=00:03:20.01 bitrate=  64.0kbits/s    
size=    1723kB time=00:03:40.48 bitrate=  64.0kbits/s    
size=    1885kB time=00:04:01.20 bitrate=  64.0kbits/s    
size=    2042kB time=00:04:21.24 bitrate=  64.0kbits/s    
size=    2195kB time=00:04:40.87 bitrate=  64.0kbits/s    
size=    2358kB time=00:05:01.72 bitrate=  64.0kbits/s    
size=    2507kB time=00:05:20.80 bitrate=  64.0kbits/s    
size=    2659kB time=00:05:40.22 bitrate=  64.0kbits/s    
size=    2827kB time=00:06:01.72 bitrate=  64.0kbits/s    
size=    2988kB time=00:06:22.36 bitrate=  64.0kbits/s    
size=    3141kB time=00:06:41.92 bitrate=  64.0kbits/s    
size=    3282kB time=00:06:59.97 bitrate=  64.0kbits/s    
size=    3438kB time=00:07:19.96 bitrate=  64.0kbits/s    
size=    3594kB time=00:07:39.98 bitrate=  64.0kbits/s    
size=    3750kB time=00:07:59.95 bitrate=  64.0kbits/s    
size=    3906kB time=00:08:19.84 bitrate=  64.0kbits/s    
size=    4052kB time=00:08:38.61 bitrate=  64.0kbits/s    
size=    4210kB time=00:08:58.80 bitrate=  64.0kbits/s    
size=    4371kB time=00:09:19.39 bitrate=  64.0kbits/s    
size=    4523kB time=00:09:38.85 bitrate=  64.0kbits/s    
size=    4679kB time=00:09:58.77 bitrate=  64.0kbits/s    
size=    4844kB time=00:10:19.99 bitrate=  64.0kbits/s    
size=    5000kB time=00:10:39.96 bitrate=  64.0kbits/s    
size=    5166kB time=00:11:01.15 bitrate=  64.0kbits/s    
size=    5325kB time=00:11:21.48 bitrate=  64.0kbits/s    
size=    5481kB time=00:11:41.52 bitrate=  64.0kbits/s    
size=    5625kB time=00:11:59.95 bitrate=  64.0kbits/s    
size=    5772kB time=00:12:18.72 bitrate=  64.0kbits/s    
size=    5911kB time=00:12:36.48 bitrate=  64.0kbits/s    
size=    6061kB time=00:12:55.75 bitrate=  64.0kbits/s    
size=    6212kB time=00:13:15.04 bitrate=  64.0kbits/s    
size=    6373kB time=00:13:35.66 bitrate=  64.0kbits/s    
size=    6525kB time=00:13:55.15 bitrate=  64.0kbits/s    
size=    6687kB time=00:14:15.84 bitrate=  64.0kbits/s    
size=    6848kB time=00:14:36.50 bitrate=  64.0kbits/s    
size=    6983kB time=00:14:53.68 bitrate=  64.0kbits/s    
size=    7039kB time=00:15:00.86 bitrate=  64.0kbits/s    

video:0kB audio:7038kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 0.003274%

Patches should be submitted to the ffmpeg-devel mailing list and not this bug tracker.

Change History (2)

comment:1 Changed 3 years ago by Einguste

  • Keywords http added

comment:2 Changed 3 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords hls crypto regression added; https http stream removed
  • Priority changed from normal to important
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from unspecified to git-master

Duplicate of ticket #4167

Note: See TracTickets for help on using tickets.