Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#4073 closed defect (fixed)

mpegvideo unspecified pixel format - autocad mpg file

Reported by: compn Owned by:
Priority: normal Component: avcodec
Version: git-master Keywords: mpeg2video
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

D:\>ffmpeg -i "newpresentation - Copy.mpg" outputtest.mpg
ffmpeg version N-66564-gc29d999 Copyright (c) 2000-2014 the FFmpeg developers

built on Oct 2 2014 00:53:44 with gcc 4.9.1 (GCC)
configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzli

b --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libblu
ray --enable-libbs2b --enable-libcaca --enable-libfreetype --enable-libgme --enable-libgsm --enable-
libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrw
b --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr -
-enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-aacenc --
enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enab
le-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-zlib

libavutil 54. 7.101 / 54. 7.101
libavcodec 56. 1.102 / 56. 1.102
libavformat 56. 7.102 / 56. 7.102
libavdevice 56. 1.100 / 56. 1.100
libavfilter 5. 1.102 / 5. 1.102
libswscale 3. 1.100 / 3. 1.100
libswresample 1. 1.100 / 1. 1.100
libpostproc 53. 1.100 / 53. 1.100

[mpeg1video @ 02dbbfc0] Invalid frame dimensions 0x0.

Last message repeated 39 times

[mpegvideo @ 02eb8820] decoding for stream 0 failed
[mpegvideo @ 02eb8820] Estimating duration from bitrate, this may be inaccurate
[mpegvideo @ 02eb8820] Could not find codec parameters for stream 0 (Video: mpeg1video, 640x480, 104
857 kb/s): unspecified pixel format
Consider increasing the value for the 'analyzeduration' and 'probesize' options
newpresentation - Copy.mpg: could not find codec parameters
Input #0, mpegvideo, from 'newpresentation - Copy.mpg':

Duration: 00:00:00.07, bitrate: 104856 kb/s

Stream #0:0: Video: mpeg1video, 640x480, 104857 kb/s, 1200k tbn

[buffer @ 02eb8600] Unable to parse option value "-1" as pixel format

Last message repeated 1 times

[buffer @ 02eb8600] Error setting option pix_fmt to value -1.
[graph 0 input from stream 0:0 @ 02eb2160] Error applying options to the filter.
Error opening filters!

Attachments (1)

newpresentation - Copy.mpg (932.1 KB) - added by compn 4 years ago.

Download all attachments as: .zip

Change History (11)

Changed 4 years ago by compn

comment:1 follow-up: Changed 4 years ago by compn

works with mplayer -vc mpeg12 file

comment:2 in reply to: ↑ 1 Changed 4 years ago by cehoyos

  • Keywords mpeg2video added
  • Type changed from enhancement to defect
  • Version changed from unspecified to git-master

Replying to compn:

works with mplayer -vc mpeg12 file

Could you provide some console output: It fails here with current MPlayer svn.

comment:3 Changed 4 years ago by cehoyos

  • Component changed from undetermined to avcodec

Needs -demuxer lavf or -fps here.

Last edited 4 years ago by cehoyos (previous) (diff)

comment:4 Changed 4 years ago by cehoyos

  • Reproduced by developer set
  • Status changed from new to open

comment:5 follow-up: Changed 4 years ago by compn

  • Component changed from avcodec to undetermined
  • Reproduced by developer unset

you need to compile mplayer with libmpeg2 for -vc mpeg12 to work.

heres output of extremely old mplayer with libmpeg2 built in

D:\>mplayerrc1 -vc mpeg12 "newpresentation - Copy.mpg" -fps 20 -v
MPlayer 1.0rc1-3.4.2 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Pentium(R) 4 CPU 3.20GHz (Family: 15, Model: 3, Stepping: 4)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Compiled with runtime CPU detection.
Warning unknown option nocorrect-pts at line 4
Warning unknown option capture at line 14
Warning unknown option doubleclick-time at line 19
get_path('codecs.conf') -> 'e:/cdrive/mplayer/mplayer/codecs.conf'
Reading e:/cdrive/mplayer/mplayer/codecs.conf: too many FourCCs/formats... at line 334
Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': No such

file or directory

Using built-in default codecs.conf.
CommandLine?: '-vc' 'mpeg12' 'newpresentation - Copy.mpg' '-fps' '20' '-v'
init_freetype
get_path('font/font.desc') -> 'e:/cdrive/mplayer/mplayer/font/font.desc'
font: can't open file: e:/cdrive/mplayer/mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
Using Windows native timing
get_path('input.conf') -> 'e:/cdrive/mplayer/mplayer/input.conf'
Parsing input config file e:/cdrive/mplayer/mplayer/input.conf
Unknown key 'AR_VUP'
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config
get_path('newpresentation - Copy.mpg.conf') -> 'e:/cdrive/mplayer/mplayer/newpresentation - Copy.mpg
.conf'

Playing newpresentation - Copy.mpg.
get_path('sub/') -> 'e:/cdrive/mplayer/mplayer/sub/'
WINSOCK2 init: 0
[file] File size is 954473 bytes
STREAM: [file] newpresentation - Copy.mpg
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
CACHE_PRE_INIT: 0 [0] 0 pre:179200 eof:0
Cache fill: 0.00% (0 bytes)
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for NuppelVideo?
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename newpresentation - Copy.mpg ext: .mpg
Checking for Nullsoft Streaming Video
Checking for MOV
Checking for VIVO
header block 1 size: 0
AVS: avs_check_file - attempting to open file newpresentation - Copy.mpg
AVS: File is too big, aborting...
Checking for PVA
Checking for MPEG-TS...
TRIED UP TO POSITION 66236, FOUND 47, packet_size= 0, SEEMS A TS? 0
Checking for LMLM4 Stream Format
Invalid packet in LMLM4 stream: ch=0 size=671211528
LMLM4 Stream Format not found
MPEG Stream reached EOF
ds_fill_buffer: EOF reached (stream: video)
MPEG packet stats: p100: 40 p101: 40 p1B6: 0 p12x: 0 sli: 40 a: 0 b: 0 c: 0 idr: 0 sps: 0 pps: 0 PE
S: 0 MP3: 349, synced: 0
MPEG-ES file format detected.
==> Found video stream: 0
Searching for sequence header... OK!
VIDEO: MPEG1 640x480 (aspect 1) 0.000 fps 0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:1 fourcc:0x10000001 size:640x480 fps: 0.00 ftime:=0.0000
get_path('sub/') -> 'e:/cdrive/mplayer/mplayer/sub/'
dvdsublang...newpresentation copy en eng
dvdsublang...newpresentation copy en eng
dvdsublang...newpresentation copy en eng
dvdsublang...newpresentation copy en eng
dvdsublang...newpresentation copy en eng
dvdsublang...newpresentation copy en eng
dvdsublang...newpresentation copy en eng
dvdsublang...newpresentation copy en eng
dvdsublang...newpresentation copy en eng
dvdsublang...newpresentation copy en eng
dvdsublang...newpresentation copy en eng
dvdsublang...newpresentation copy en eng
dvdsublang...newpresentation copy en eng
<vo_directx><INFO>checking primary surface
<vo_directx><FORMAT PRIMARY>14 BGR32 supported
<vo_directx><INFO>testing supported overlay pixelformats
<vo_directx><FORMAT OVERLAY>0 YV12 supported
<vo_directx><FORMAT OVERLAY>1 I420 supported
<vo_directx><FORMAT OVERLAY>2 IYUV supported
<vo_directx><FORMAT OVERLAY>3 YVU9 supported
<vo_directx><FORMAT OVERLAY>4 YUY2 supported
<vo_directx><FORMAT OVERLAY>5 UYVY supported
<vo_directx><FORMAT OVERLAY>6 BGR8 not supported
<vo_directx><FORMAT OVERLAY>7 RGB15 not supported
<vo_directx><FORMAT OVERLAY>8 BGR15 not supported
<vo_directx><FORMAT OVERLAY>9 RGB16 not supported
<vo_directx><FORMAT OVERLAY>10 BGR16 not supported
<vo_directx><FORMAT OVERLAY>11 RGB24 not supported
<vo_directx><FORMAT OVERLAY>12 BGR24 not supported
<vo_directx><FORMAT OVERLAY>13 RGB32 not supported
<vo_directx><FORMAT OVERLAY>14 BGR32 not supported
<vo_directx><INFO>Your card supports 6 of 15 overlayformats
<vo_directx><INFO>can mirror left right
<vo_directx><INFO>can mirror up down
<vo_directx><INFO>hardware supports overlay
Opening video filter: [scale]
SwScale? params: -1 x -1 (-1=no scaling)
Opening video filter: [eq]
==========================================================================
Forced video codec: mpeg12
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm: libmpeg2 (MPEG-1 or 2 (libmpeg2))
==========================================================================
Audio: no sound
Freeing 0 unused audio chunks.
FPS forced to be 20.000 (ftime: 0.050).
Starting playback...
VDec: vo config request - 640 x 480 (preferred colorspace: Planar YV12)
Trying filter chain: eq scale vo
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO Config (640x480->640x480,flags=0,'MPlayer',0x32315659)
REQ: flags=0x457 req=0x0
SwScaler?: using unscaled yuv420p -> yuv420p special converter
REQ: flags=0x417 req=0x0
VO: [directx] 640x480 => 640x480 Planar YV12
VO: Description: Directx DDraw YUV/RGB/BGR renderer
VO: Author: Sascha Sommer <saschasommer@freenet.de>
<vo_directx><INFO>overlay with format YV12 created
* [eq] Allocating mp_image_t, 640x480x12bpp YUV planar, 460800 bytes
* [eq] Allocating mp_image_t, 640x480x12bpp YUV planar, 460800 bytes
* [scale] Exporting mp_image_t, 640x480x12bpp YUV planar, 460800 bytes
* [vo] Direct Rendering mp_image_t, 640x480x12bpp YUV planar, 460800 bytes
get_path('subfont.ttf') -> 'e:/cdrive/mplayer/mplayer/subfont.ttf'
Unicode font: 584 glyphs.
Uninit video: libmpeg21% 0.0% 0 0 42%
WINSOCK2 uninit

Exiting... (Quit)

comment:6 Changed 4 years ago by compn

  • Component changed from undetermined to avcodec
  • Reproduced by developer set

oops, i didnt unset those things. trac did it , not me.

comment:7 in reply to: ↑ 5 Changed 4 years ago by cehoyos

Replying to compn:

you need to compile mplayer with libmpeg2 for -vc mpeg12 to work.

Of course.
But you also added -fps to your command line.

comment:8 Changed 4 years ago by compn

yes, otherwise it says
FPS not specified in the header or invalid, use the -fps option.

comment:9 Changed 4 years ago by michael

  • Resolution set to fixed
  • Status changed from open to closed

comment:10 Changed 4 years ago by cehoyos

There is still an issue when seeking (backwards).

Note: See TracTickets for help on using tickets.