Opened 5 years ago

Closed 5 years ago

#3984 closed defect (needs_more_info)

Compiling libutvideodec fails: intmath.h not found

Reported by: LigH Owned by:
Priority: normal Component: avcodec
Version: git-master Keywords: libutvideo
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

Compiling a static non-free build of ffmpeg in the media-autobuild_suite by jb_alvarado (in an MSYS2 Win64 environment) fails trying to compile libutvideocodec for libavcodec because it can't find intmath.h

How to reproduce:

Use https://github.com/jb-alvarado/media-autobuild_suite set up for MSYS2 and Win64 cross-compile to build static, non-free versions. It stops with the last output as in the attached text (to avoid Wiki formatting confusion).

The reason may be that using "--enable-libutvideo" is deprecated since Ut Video codec support is native (according to Daemon404).

Attachments (1)

bug.txt (655 bytes) - added by LigH 5 years ago.
last part of GCC output with error message

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by LigH

last part of GCC output with error message

comment:1 Changed 5 years ago by cehoyos

Please run make V=1 ffmpeg.exe twice and post the complete, uncut console output of the second run.

Note that intmath.h is part of FFmpeg (you can find it in the libavutil subdirectory ), so I really don't see how this could be a problem that we can fix.

comment:2 Changed 5 years ago by cehoyos

  • Keywords libutvideo added
  • Resolution set to needs_more_info
  • Status changed from new to closed

Please reopen this ticket if you can add more information.

Note: See TracTickets for help on using tickets.