Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#3972 closed defect (invalid)

-hls_flags are not enabled or it doesn't work

Reported by: ddrdark Owned by:
Priority: normal Component: undetermined
Version: 2.4.1 Keywords: hls
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
I would like to use the -hls_flags but I can't get it working. I've tried downloading the latest compiled ffmpeg and also tried to compile mine with the option --enable-muxer=hls.

It's listed on the documentation https://www.ffmpeg.org/ffmpeg-all.html#Options-26

I get this error

Jonatans-iMac:FFmpeg-n2.4.1 jonatan$ ./ffmpeg -i /Users/jonatan/test.mp4 -hls_flags single_file output.m3u8
ffmpeg version 2.4.1 Copyright (c) 2000-2014 the FFmpeg developers

built on Sep 23 2014 18:46:20 with Apple LLVM version 6.0 (clang-600.0.51) (based on LLVM 3.5svn)
configuration: --enable-muxer=hls
libavutil 54. 7.100 / 54. 7.100
libavcodec 56. 1.100 / 56. 1.100
libavformat 56. 4.101 / 56. 4.101
libavdevice 56. 0.100 / 56. 0.100
libavfilter 5. 1.100 / 5. 1.100
libswscale 3. 0.100 / 3. 0.100
libswresample 1. 1.100 / 1. 1.100

Unrecognized option 'hls_flags'.
Error splitting the argument list: Option not found

On the GitHub? repository it also says that all the Muxers are enabled by default so it should work even without the --enable-muxer=hls option.

Would be greatly appreciated any help! Thanks a lot for your time.

Change History (3)

comment:1 Changed 5 years ago by cehoyos

  • Keywords hls_flags removed
  • Priority changed from important to normal
  • Resolution set to invalid
  • Status changed from new to closed

The documentation you read is for current FFmpeg git head, in the documentation that comes with FFmpeg 2.4 (and 2.4.1) you will not find any mention of -hls_flags (because it doesn't exist).

comment:2 follow-up: Changed 5 years ago by cehoyos

  • Version changed from unspecified to 2.4.1

comment:3 in reply to: ↑ 2 Changed 5 years ago by ddrdark

Replying to cehoyos:
Hello cehoyos

I'm so sorry for the confusion. I thought the documentation was for the "stable" release. I have just cloned the repo and it's working fine.

Thanks for your time.

Note: See TracTickets for help on using tickets.