Opened 5 years ago

Closed 5 years ago

#3945 closed enhancement (duplicate)

Unable to decode R3D file

Reported by: mrskman Owned by:
Priority: wish Component: avformat
Version: git-master Keywords: r3d
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Hi,

I'm not sure if this is a bug or if libopenjpeg v2.0 (which is not supported if I understand it correctly) is needed or if R3D files are not supported.

Here is first 2MB from ~730MB file which I'm not able to convert.
http://www.datafilehost.com/d/b3e20e33

If you need larger sample, let me know.

ffmpeg started on 2014-09-12 at 09:44:27
Report written to "ffmpeg-20140912-094427.log"
Command line:
ffmpeg -v 9 -loglevel 99 -report -i R3D_2MB_sample.r3d -f null -
ffmpeg version 2.3.3 Copyright (c) 2000-2014 the FFmpeg developers
  built on Aug 19 2014 09:59:05 with gcc 4.4.3 (Ubuntu 4.4.3-4ubuntu5.1)
  configuration: --prefix=/home/mrskman/ffmpeg-2.3.3/build --extra-ldflags='-Wl,-rpath,/home/mrskman/ffmpeg-2.3.3/build/lib-L/home/mrskman/ffmpeg-2.3.3/build/lib' --bindir=/home/mrskman/ffmpeg-2.3.3/build/bin --enable-shared --disable-static --disable-doc --disable-htmlpages --disable-manpages --disable-podpages --disable-txtpages --enable-gpl --enable-libbluray --enable-libcelt --enable-libfdk-aac --enable-libgme --enable-libgsm --enable-libilbc --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libwebp --enable-libx264 --enable-nonfree --enable-version3
  libavutil      52. 92.100 / 52. 92.100
  libavcodec     55. 69.100 / 55. 69.100
  libavformat    55. 48.100 / 55. 48.100
  libavdevice    55. 13.102 / 55. 13.102
  libavfilter     4. 11.100 /  4. 11.100
  libswscale      2.  6.100 /  2.  6.100
  libswresample   0. 19.100 /  0. 19.100
  libpostproc    52.  3.100 / 52.  3.100
Splitting the commandline.
Reading option '-v' ... matched as option 'v' (set logging level) with argument '9'.
Reading option '-loglevel' ... matched as option 'loglevel' (set logging level) with argument '99'.
Reading option '-report' ... matched as option 'report' (generate a report) with argument '1'.
Reading option '-i' ... matched as input file with argument 'R3D_2MB_sample.r3d'.
Reading option '-f' ... matched as option 'f' (force format) with argument 'null'.
Reading option '-' ... matched as output file.
Finished splitting the commandline.
Parsing a group of options: global .
Applying option v (set logging level) with argument 9.
Applying option loglevel (set logging level) with argument 99.
Applying option report (generate a report) with argument 1.
Successfully parsed a group of options.
Parsing a group of options: input file R3D_2MB_sample.r3d.
Successfully parsed a group of options.
Opening an input file: R3D_2MB_sample.r3d.
[r3d @ 0x9bf6e00] Format r3d probed with size=2048 and score=100
[r3d @ 0x9bf6e00] error reading end atom
[r3d @ 0x9bf6e00] Before avformat_find_stream_info() pos: 324 bytes read:32824 seeks:2
[jpeg2000 @ 0x9bf7600] unsupported marker 0x8ABF at pos 0x21D2
[jpeg2000 @ 0x9bf7600] unsupported marker 0x4ECB at pos 0x98D7
[jpeg2000 @ 0x9bf7600] unsupported marker 0x66E7 at pos 0xEBC0
[jpeg2000 @ 0x9bf7600] unsupported marker 0x4629 at pos 0x12FAF
[jpeg2000 @ 0x9bf7600] unsupported marker 0x92FD at pos 0x166C9
[jpeg2000 @ 0x9bf7600] unsupported marker 0xCFA8 at pos 0x18061
[jpeg2000 @ 0x9bf7600] unsupported marker 0x9D4F at pos 0x1EDF4
[jpeg2000 @ 0x9bf7600] unsupported marker 0xC45A at pos 0x233B8
[jpeg2000 @ 0x9bf7600] unsupported marker 0x63FA at pos 0x2352C
[jpeg2000 @ 0x9bf7600] unsupported marker 0x2F5E at pos 0x2E668
[jpeg2000 @ 0x9bf7600] unsupported marker 0x53E7 at pos 0x3802C
[jpeg2000 @ 0x9bf7600] unsupported marker 0x2F6A at pos 0x3A4FC
[jpeg2000 @ 0x9bf7600] unsupported marker 0x6A9B at pos 0x463EF
[jpeg2000 @ 0x9bf7600] unsupported marker 0x122B at pos 0x47A26
[jpeg2000 @ 0x9bf7600] unsupported marker 0x888C at pos 0x533B9
[jpeg2000 @ 0x9bf7600] unsupported marker 0x61E0 at pos 0x5CE3B
[jpeg2000 @ 0x9bf7600] unsupported marker 0x89A2 at pos 0x6C652
[jpeg2000 @ 0x9bf7600] unsupported marker 0x8B83 at pos 0x7674F
[jpeg2000 @ 0x9bf7600] unsupported marker 0xA5BA at pos 0x7B751
[jpeg2000 @ 0x9bf7600] unsupported marker 0x3D57 at pos 0x7FEBB
[jpeg2000 @ 0x9bf7600] unsupported marker 0x5BF7 at pos 0x87DBB
[jpeg2000 @ 0x9bf7600] unsupported marker 0x378A at pos 0x8C50C
[jpeg2000 @ 0x9bf7600] unsupported marker 0x144D at pos 0x99208
[jpeg2000 @ 0x9bf7600] unsupported marker 0x0D28 at pos 0x9E3F3
[jpeg2000 @ 0x9bf7600] unsupported marker 0xE7AE at pos 0xA6DC1
[jpeg2000 @ 0x9bf7600] unsupported marker 0xE6B3 at pos 0xB4C93
[jpeg2000 @ 0x9bf7600] unsupported marker 0xE5A0 at pos 0xB8311
[jpeg2000 @ 0x9bf7600] unsupported marker 0x8C98 at pos 0xC73D6
[jpeg2000 @ 0x9bf7600] unsupported marker 0x2EC9 at pos 0xD590F
[jpeg2000 @ 0x9bf7600] unsupported marker 0xB3CA at pos 0xE49D4
[jpeg2000 @ 0x9bf7600] unsupported marker 0xFA87 at pos 0xF0943
[jpeg2000 @ 0x9bf7600] unsupported marker 0x0D55 at pos 0xF3155
[jpeg2000 @ 0x9bf7600] unsupported marker 0x79C6 at pos 0xFB1A6
[jpeg2000 @ 0x9bf7600] unsupported marker 0xE2EB at pos 0x1021B4
[jpeg2000 @ 0x9bf7600] unsupported marker 0xC8B3 at pos 0x103512
[jpeg2000 @ 0x9bf7600] unsupported marker 0x6D94 at pos 0x108AA2
[jpeg2000 @ 0x9bf7600] unsupported marker 0xA5AA at pos 0x116BBB
[jpeg2000 @ 0x9bf7600] unsupported marker 0x6E0E at pos 0x121F3B
[jpeg2000 @ 0x9bf7600] unsupported marker 0xD9AA at pos 0x12BE2B
[jpeg2000 @ 0x9bf7600] unsupported marker 0x2500 at pos 0x12CE31
[jpeg2000 @ 0x9bf7600] unsupported marker 0x5546 at pos 0x13B3AF
[jpeg2000 @ 0x9bf7600] unsupported marker 0xE711 at pos 0x1470FD
[jpeg2000 @ 0x9bf7600] unsupported marker 0xCA82 at pos 0x14D165
[jpeg2000 @ 0x9bf7600] unsupported marker 0x4E2B at pos 0x15AE76
[jpeg2000 @ 0x9bf7600] unsupported marker 0x25A6 at pos 0x169B3B
[jpeg2000 @ 0x9bf7600] unsupported marker 0x464B at pos 0x17182D
[jpeg2000 @ 0x9bf7600] unsupported marker 0x5CAE at pos 0x1738E1
[jpeg2000 @ 0x9bf7600] unsupported marker 0xDA43 at pos 0x17F70D
[jpeg2000 @ 0x9bf7600] unsupported marker 0xD594 at pos 0xAD09
[jpeg2000 @ 0x9bf7600] unsupported marker 0xF70C at pos 0x124CA
[jpeg2000 @ 0x9bf7600] unsupported marker 0x00B2 at pos 0x21621
[jpeg2000 @ 0x9bf7600] unsupported marker 0xCB03 at pos 0x29FAD
[jpeg2000 @ 0x9bf7600] unsupported marker 0x6172 at pos 0x2FFDD
[jpeg2000 @ 0x9bf7600] unsupported marker 0x70E7 at pos 0x39E2B
[jpeg2000 @ 0x9bf7600] unsupported marker 0x9D9C at pos 0x3D426
[jpeg2000 @ 0x9bf7600] unsupported marker 0x81C0 at pos 0x40DFC
[jpeg2000 @ 0x9bf7600] unsupported marker 0xF4C6 at pos 0x44A8A
[jpeg2000 @ 0x9bf7600] unsupported marker 0x1594 at pos 0x49E01
[jpeg2000 @ 0x9bf7600] unsupported marker 0xBF0E at pos 0x4C84F
[jpeg2000 @ 0x9bf7600] unsupported marker 0x0356 at pos 0x53B4D
[jpeg2000 @ 0x9bf7600] unsupported marker 0x9930 at pos 0x57D18
[jpeg2000 @ 0x9bf7600] unsupported marker 0xC90C at pos 0x58C79
[r3d @ 0x9bf6e00] decoding for stream 0 failed
[r3d @ 0x9bf6e00] Could not find codec parameters for stream 0 (Video: jpeg2000, 4096x2304, 1/48000): unspecified pixel format
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[r3d @ 0x9bf6e00] After avformat_find_stream_info() pos: 2097152 bytes read:2129652 seeks:2 frames:3
Guessed Channel Layout for  Input Stream #0.1 : stereo
Input #0, r3d, from 'R3D_2MB_sample.r3d':
  Duration: N/A, start: 0.000000, bitrate: N/A
    Stream #0:0, 2, 1/48000: Video: jpeg2000, 4096x2304, 1/48000, 25 fps, 25 tbr, 48k tbn, 48k tbc
    Metadata:
      filename        : A015_C017_0824PB_001.R3D
    Stream #0:1, 1, 1/48000: Audio: pcm_s32be, 48000 Hz, 2 channels, s32, 3072 kb/s
Successfully opened the file.
Parsing a group of options: output file -.
Applying option f (force format) with argument null.
Successfully parsed a group of options.
Opening an output file: -.
Successfully opened the file.
detected 2 logical cores
[graph 0 input from stream 0:0 @ 0x9be9ce0] Setting 'video_size' to value '4096x2304'
[graph 0 input from stream 0:0 @ 0x9be9ce0] Setting 'pix_fmt' to value '-1'
[buffer @ 0x9be9a40] Unable to parse option value "-1" as pixel format
[graph 0 input from stream 0:0 @ 0x9be9ce0] Setting 'time_base' to value '1/48000'
[graph 0 input from stream 0:0 @ 0x9be9ce0] Setting 'pixel_aspect' to value '0/1'
[graph 0 input from stream 0:0 @ 0x9be9ce0] Setting 'sws_param' to value 'flags=2'
[graph 0 input from stream 0:0 @ 0x9be9ce0] Setting 'frame_rate' to value '25000/1000'
[buffer @ 0x9be9a40] Unable to parse option value "-1" as pixel format
[buffer @ 0x9be9a40] Error setting option pix_fmt to value -1.
[graph 0 input from stream 0:0 @ 0x9be9ce0] Error applying options to the filter.
Error opening filters!
[AVIOContext @ 0x9bf68e0] Statistics: 2129652 bytes read, 2 seeks

Attachments (1)

R3D_2MB_sample.r3d (2.0 MB) - added by cehoyos 5 years ago.

Download all attachments as: .zip

Change History (2)

Changed 5 years ago by cehoyos

comment:1 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords r3d added
  • Priority changed from normal to wish
  • Resolution set to duplicate
  • Status changed from new to closed
  • Type changed from defect to enhancement
  • Version changed from 2.3.3 to git-master

This is a duplicate of ticket #2690: Version 4 files are not supported.

Note: See TracTickets for help on using tickets.