Opened 3 years ago

Closed 3 years ago

#3917 closed defect (duplicate)

SRTP not encrypting video

Reported by: bone2006 Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: SRTP
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description (last modified by cehoyos)

Summary of the bug: SRTP does not seem to be working
How to reproduce:

% ffmpeg -i input -vcodec libx264 -b:v 10M -g 20 -preset ultrafast -f mpegts "srtp://127.0.0.1:7777?srtp_out_suite=SRTP_AES_CM_128_HMAC_SHA1_32&srtp_out_params=PS1uQCVeeCFCanVmcjkpPywjNWhcYD0mXXtxaVBR|2^20|1:4"

I have tried using the command above and it seems SRTP isn't encrypting the video

Change History (4)

comment:1 Changed 3 years ago by bone2006

if you use ffplay -f mpegts "udp://127.0.0.1:7777". The video stream can be viewed clearly.

comment:2 Changed 3 years ago by cehoyos

  • Description modified (diff)

Please add the complete, uncut console output to make this a valid ticket.

comment:3 Changed 3 years ago by thovo

This report is similar to http://trac.ffmpeg.org/ticket/3533.
With the current git master you cannot use mpegts and (s)rtp at the same time and a/v stream.

Since patch 5ab46704 the command line gives a short hint:
"Data doesn't look like RTP packets, make sure the RTP muxer is used"

comment:4 Changed 3 years ago by thovo

  • Resolution set to duplicate
  • Status changed from new to closed

See "RTP packetizing for MPEG-TS (RFC 2250)" (http://trac.ffmpeg.org/ticket/4176)

Note: See TracTickets for help on using tickets.