Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#3908 closed defect (needs_more_info)

vf_hue copyright, do mplayer authors get copyright in the ported filter?

Reported by: compn Owned by:
Priority: normal Component: avfilter
Version: git-master Keywords: hue license
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

if not, why not?

carl. clement, reimar, diego are not listed in the copyright in libavfilter. some of their code may not be in the port.

some complaints have been made that we are not taking copyright seriously in ffmpeg. or that we have not attributed code 100%.

Change History (15)

comment:1 Changed 5 years ago by compn

if not copyright, do they get contribution credit?

like 'these people helped craft this file from mplayer'
reimar
diego
carl
clement
..

comment:2 follow-up: Changed 5 years ago by cehoyos

The complaints are made by people who intentionally break copyright all the time (or in other words: who are thieves). Why don't you point to a missing copyright or - even better - send a patch?

comment:3 in reply to: ↑ 2 ; follow-up: Changed 5 years ago by ubitux

  • Keywords hue license added
  • Resolution set to needs_more_info
  • Status changed from new to closed

The hue filter in MPlayer is 200 lines of code. The port basically kept only the main processing function. The author of this code has been asked for relicensing.

The Copyright in libavfilter does contain both original authors and it's fine, no other header in the codebase contains all the contributors in Copyright. If you think hue filter is violating a copyright, please be more specific.

some complaints have been made that we are not taking copyright seriously in ffmpeg. or that we have not attributed code 100%.

j-b was trying to make a point yesterday on IRC and picked random examples more or less accurate, such as mentioning the vf_interlace thing from Libav commits.

We might make mistakes at times about copyright and we course need to address them. But this ticket doesn't help here.

Replying to cehoyos:

The complaints are made by people who intentionally break copyright all the time (or in other words: who are thieves). Why don't you point to a missing copyright or - even better - send a patch?

No, j-b is not from Libav (which I suppose you are talking about) but from Videolan who is providing the FFmpeg project some Git hosting. Also, please stop calling them "thieves", true or not this is not a professional behavior and there is no need to give them more reasons to hate us, especially when this is related to events from 3 years ago. We are currently trying (without success I admit) to create some kind of cooperation, and such remarks definitely won't help.

comment:4 Changed 5 years ago by gjdfgh

or in other words: who are thieves

Please stop this. It doesn't make you sound very clever, and just heats the flames in the ongoing attempts to make progress FFmpeg and Libav reconcile. Or in other words, please don't make it harder than it is.

Last edited 5 years ago by gjdfgh (previous) (diff)

comment:5 follow-ups: Changed 5 years ago by cehoyos

I missed the comment from J-B, sorry! I saw some remarks from the thieves though (on the very same day that copyright violations were committed to their repository!) accusing FFmpeg of bad behaviour regarding open-source software licenses.

There is apparently some misunderstanding regarding the word thieve (and liar): Some people seem to believe that this is meant as an insult which is of course not true. I did send some insults to the mailing list three years ago (after having read that commit rights are to much responsibility for me and after MPlayer infrastructure was stolen). Nowadays I just find it necessary to make it completely clear that the usual mails sent by the avconv developers contain obvious lies and that copyright violators are thieves imo.

comment:6 in reply to: ↑ 5 ; follow-up: Changed 5 years ago by Cigaes

Replying to cehoyos:

that copyright violators are thieves imo.

You are doubly wrong in this.

First, if you know of a specific copyright violation, then point it, and see if they correct it. Otherwise, you are just slandering.

Second, copyright violators are not thieves. So-called intellectual property has nothing in common with real, physical property. The discourse of mixing both is exactly the base argument of IP trolls pushing for harder DRM protections and such.

comment:7 in reply to: ↑ 5 Changed 5 years ago by ubitux

Replying to cehoyos:

There is apparently some misunderstanding regarding the word thieve (and liar): Some people seem to believe that this is meant as an insult which is of course not true. I did send some insults to the mailing list three years ago (after having read that commit rights are to much responsibility for me and after MPlayer infrastructure was stolen). Nowadays I just find it necessary to make it completely clear that the usual mails sent by the avconv developers contain obvious lies and that copyright violators are thieves imo.

WTF are you talking about. Again, please stop this.

comment:8 follow-up: Changed 5 years ago by gjdfgh

There is apparently some misunderstanding regarding the word thieve (and liar): Some people seem to believe that this is meant as an insult which is of course not true.

That's just... completely out of this world. No, you can't hide your insults behind trying to explain them rationally.

Libav didn't steal anything. The infrastructure they grabbed was theirs, and also they were a part of ffmpeg at the time of the fork (the separate ffmpeg identity was created only later when MiNi? and some others declared they wanted to continue under the name ffmpeg).

comment:9 in reply to: ↑ 6 ; follow-up: Changed 5 years ago by cehoyos

Replying to Cigaes:

Replying to cehoyos:

that copyright violators are thieves imo.

You are doubly wrong in this.

First, if you know of a specific copyright violation, then point it, and see if they correct it. Otherwise, you are just slandering.

6c1df1f2 comes to mind but please remember that it was discussed on avconv-devel that it is ok to remove author attribution if some whitespace is changed. And please look at the copyright of avconv.c.

Second, copyright violators are not thieves. So-called intellectual property has nothing in common with real, physical property. The discourse of mixing both is exactly the base argument of IP trolls pushing for harder DRM protections and such.

I am not a native speaker but I really do believe that stealing code is neither better than stealing real, physical property nor does it make a large difference.

comment:10 in reply to: ↑ 8 Changed 5 years ago by cehoyos

Replying to gjdfgh:

The infrastructure they grabbed was theirs

Please don't believe their lies: The infrastructure belonged to the group of MPlayer developer and they were not asked if they agreed with the actions taken then.

comment:11 follow-up: Changed 5 years ago by gjdfgh

Well, we're not native speakers either. In any case, please stop obsessing over what happened in 2011.

comment:12 in reply to: ↑ 9 Changed 5 years ago by Cigaes

Replying to cehoyos:

I am not a native speaker but I really do believe that stealing code is neither better than stealing real, physical property nor does it make a large difference.

It is not a matter of being a native speaker: you still have your code, so they did not steal it. Physical property stealing is different: if you have an pear and I steal it, you have your pear no longer.

And here is not the place for that kind of argument anyway.

comment:13 in reply to: ↑ 11 Changed 5 years ago by cehoyos

Replying to gjdfgh:

Well, we're not native speakers either. In any case, please stop obsessing over what happened in 2011.

I am talking about current commits and emails, what are you talking about?

comment:14 in reply to: ↑ 3 Changed 5 years ago by compn

Replying to ubitux:

some complaints have been made that we are not taking copyright seriously in ffmpeg. or that we have not attributed code 100%.

j-b was trying to make a point yesterday on IRC and picked random examples more or less accurate, such as mentioning the vf_interlace thing from Libav commits.

We might make mistakes at times about copyright and we course need to address them. But this ticket doesn't help here.

did you see the entire conversation with j-b? i dont think i was able to convince him of the copyright of vf_hue. were you able to quash all of his concerns? if not, this bug should be open.

i made this bug because j-b would not create the bug himself.
j-b still has concerns about this file and other files in ffmpeg from what i could tell.
if you do not want to address his concerns, that is fine too. but i am curious if there are any other devels who do want to address j-b's concerns.

comment:15 in reply to: ↑ description Changed 5 years ago by saste

Replying to compn:

if not, why not?

carl. clement, reimar, diego are not listed in the copyright in libavfilter. some of their code may not be in the port.

some complaints have been made that we are not taking copyright seriously in ffmpeg. or that we have not attributed code 100%.

I'm one of the authors of the port. Jeremy Tran worked on the port as a SOCIS2102 student. The filter was basically rewritten from scratch, the only relevant part of code which was copied was in the process_chrominance routine authored by Michael Niedermayer, who is referenced in the file header as copyright holder. The original license (GPLv.2) was kept for the port.
Then the code was relicensed to LGPL with the consent of all the port contributors (see commit 771e2e59e2afeba6f195645678645b8c874e59a2).

Keep in mind that when doing a port it is not possible to state with complete accuracy what is the authorship of the ported code. Also from my reading of the mplayer log I see no relevant contributions which went in the port but for the code in the mentioned processing routine. That said, IANAL but I tend to use common sense when evaluating such copyright issues, and I consider that the copyright attribution of the port is accurate.

Thus I suggest to consider invalid this issue.

Last edited 5 years ago by saste (previous) (diff)
Note: See TracTickets for help on using tickets.