Opened 5 years ago

Closed 5 years ago

#3837 closed defect (fixed)

ffplay: vc1 crash

Reported by: ami_stuff Owned by:
Priority: important Component: avcodec
Version: git-master Keywords: vc1 SIGSEGV crash regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

I also get the crash with d34ec64 07-Aug-2014 autobuild.

http://www.datafilehost.com/d/9bef7ed5

$ gdb ffplay_g.exe
GNU gdb (GDB) 7.4
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-pc-mingw32".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from D:\MinGW\msys\1.0\ffmpeg-HEAD-b96c951\ffplay_g.exe...done.
(gdb) r santa06.wmv
Starting program: D:\MinGW\msys\1.0\ffmpeg-HEAD-b96c951\ffplay_g.exe santa06.wmv

[New Thread 1768.0xe28]
[New Thread 1768.0xfd0]
[New Thread 1768.0xdc8]
[New Thread 1768.0xcc]
[New Thread 1768.0xa40]
[New Thread 1768.0xc8c]
[New Thread 1768.0xfcc]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1768.0xfcc]
vc1_sprite_flush (avctx=0x584fbe0) at libavcodec/vc1dec.c:5495
5495        if (f->data[0])
(gdb) bt
#0  vc1_sprite_flush (avctx=0x584fbe0) at libavcodec/vc1dec.c:5495
#1  0x005caabf in avcodec_flush_buffers (avctx=0x584fbe0)
    at libavcodec/utils.c:3066
#2  0x0040d0e2 in get_video_frame (serial=<optimized out>,
    pkt=<optimized out>, frame=<optimized out>, is=<optimized out>)
    at ffplay.c:1690
#3  video_thread (arg=0x5b20040) at ffplay.c:1974
#4  0x681097d2 in SDL_RunThread (data=0x5eb6ba0)
    at ./src/thread/SDL_thread.c:204
#5  0x681327cf in RunThread (data=0x5e67bc8)
    at ./src/thread/win32/SDL_systhread.c:74
#6  RunThreadViaBeginThreadEx (data=0x5e67bc8)
    at ./src/thread/win32/SDL_systhread.c:95
#7  0x77c2a3b0 in msvcrt!_endthreadex () from C:\WINDOWS\system32\msvcrt.dll
#8  0x7c80b729 in KERNEL32!GetModuleFileNameA ()
   from C:\WINDOWS\system32\kernel32.dll
#9  0x00000000 in ?? ()
(gdb)

Attachments (1)

santa06_cut.wmv (2.4 MB) - added by cehoyos 5 years ago.

Change History (4)

comment:1 Changed 5 years ago by Timothy_Gu

  • Keywords SIGSEGV crash added
  • Priority changed from normal to important
  • Version changed from unspecified to git-master

comment:2 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avcodec
  • Keywords vc1 regression added
  • Reproduced by developer set
  • Status changed from new to open

Regression since 59a53842

Changed 5 years ago by cehoyos

comment:3 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Fixed by Michael in 6801eb0a

Note: See TracTickets for help on using tickets.