Opened 5 years ago

Closed 5 years ago

#3824 closed defect (fixed)

HTTPS->HTTP redirects fail (and confuse the SSL lib)

Reported by: 11rcombs Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: http
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Due to an issue in http_open_cnx: we goto redo; but never reset lower_proto to "tcp", so we try to hit the server we were redirected to via TLS on port 80. This could be fixed by inserting lower_proto = "tcp"; before the goto.

Change History (1)

comment:1 Changed 5 years ago by cehoyos

  • Keywords http added
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in c2a170ac

Note: See TracTickets for help on using tickets.