Opened 5 years ago

Closed 5 years ago

#3793 closed defect (fixed)

ffmpeg fails with "3dnow" and "3dnowext" cpuflags

Reported by: jamal Owned by:
Priority: important Component: avutil
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
$subject

How to reproduce:

% ffmpeg -cpuflags 3dnow -i input
ffmpeg version N-64909-g1df2f7b Copyright (c) 2000-2014 the FFmpeg developers
  built on Jul 22 2014 22:57:59 with gcc 4.8.3 (GCC)
  configuration: --enable-gpl --prefix=/mingw32
  libavutil      52. 92.101 / 52. 92.101
  libavcodec     55. 69.100 / 55. 69.100
  libavformat    55. 48.101 / 55. 48.101
  libavdevice    55. 13.102 / 55. 13.102
  libavfilter     4. 11.102 /  4. 11.102
  libswscale      2.  6.100 /  2.  6.100
  libswresample   0. 19.100 /  0. 19.100
  libpostproc    52.  3.100 / 52.  3.100
[cpuflags @ 0028fa8c] [Eval @ 0028f4dc] Invalid chars 'now' at the end of expression '3dnow'
[cpuflags @ 0028fa8c] Unable to parse option value "3dnow"
Failed to set value 'mmx+mmxext+3dnow' for option 'cpuflags': Error number -22 occurred
Error parsing global options: Error number -22 occurred

This is a regression since 265dadbe7de5e0f35faeedf0a76a823cbc71cd72

Change History (1)

comment:1 Changed 5 years ago by jamal

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.