Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#374 closed defect (fixed)

Artefacts with packed B frames

Reported by: cehoyos Owned by:
Priority: important Component: avcodec
Version: git-master Keywords: regression asp
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

$ ffmpeg version N-31715-g1c54806, Copyright (c) 2000-2011 the FFmpeg developers
  built on Aug  1 2011 01:24:30 with gcc 4.5.3
  configuration: --cc=/usr/local/gcc-4.5.3/bin/gcc --enable-gpl
  libavutil    51. 11. 1 / 51. 11. 1
  libavcodec   53.  9. 0 / 53.  9. 0
  libavformat  53.  6. 0 / 53.  6. 0
  libavdevice  53.  2. 0 / 53.  2. 0
  libavfilter   2. 27. 5 /  2. 27. 5
  libswscale    2.  0. 0 /  2.  0. 0
  libpostproc  51.  2. 0 / 51.  2. 0
[mpeg4 @ 0x12d84a0] Invalid and inefficient vfw-avi packed B frames detected

Seems stream 0 codec frame rate differs from container frame rate: 30000.00 (30000/1) -> 25.00 (25/1)
Input #0, avi, from 'getting_stuck.avi':
  Duration: 00:00:15.00, start: 0.000000, bitrate: 689 kb/s
    Stream #0.0: Video: mpeg4, yuv420p, 640x360 [SAR 1:1 DAR 16:9], 25 fps, 25 tbr, 25 tbn, 30k tbc
    Stream #0.1: Audio: mp3, 44100 Hz, stereo, s16, 128 kb/s
[buffer @ 0x12d6360] w:640 h:360 pixfmt:yuv420p tb:1/1000000 sar:1/1 sws_param:
Output #0, avi, to 'out.avi':
  Metadata:
    ISFT            : Lavf53.6.0
    Stream #0.0: Video: mpeg4, yuv420p, 640x360 [SAR 1:1 DAR 16:9], q=2-31, 200 kb/s, 25 tbn, 25 tbc
Stream mapping:
  Stream #0.0 -> #0.0
Press [q] to stop, [?] for help
[mpeg4 @ 0x12d84a0] Invalid and inefficient vfw-avi packed B frames detected
[mpeg4 @ 0x12d84a0] ac-tex damaged at 6 5
[mpeg4 @ 0x12d84a0] Error at MB: 211
[mpeg4 @ 0x12d84a0] concealing 818 DC, 818 AC, 818 MV errors
[mpeg4 @ 0x12d84a0] 1. marker bit missing in 3. esc
[mpeg4 @ 0x12d84a0] Error at MB: 276
[mpeg4 @ 0x12d84a0] concealing 750 DC, 750 AC, 750 MV errors
[mpeg4 @ 0x12d84a0] ac-tex damaged at 38 1
[mpeg4 @ 0x12d84a0] Error at MB: 79
[mpeg4 @ 0x12d84a0] concealing 920 DC, 920 AC, 920 MV errors
[mpeg4 @ 0x12d84a0] 2. marker bit missing in 3. esc
[mpeg4 @ 0x12d84a0] Error at MB: 277
[mpeg4 @ 0x12d84a0] concealing 830 DC, 830 AC, 830 MV errors
[mpeg4 @ 0x12d84a0] ac-tex damaged at 4 5
[mpeg4 @ 0x12d84a0] Error at MB: 209
[mpeg4 @ 0x12d84a0] concealing 920 DC, 920 AC, 920 MV errors
[mpeg4 @ 0x12d84a0] 1. marker bit missing in 3. esc
[mpeg4 @ 0x12d84a0] Error at MB: 90
[mpeg4 @ 0x12d84a0] concealing 920 DC, 920 AC, 920 MV errors
[mpeg4 @ 0x12d84a0] ac-tex damaged at 18 2
[mpeg4 @ 0x12d84a0] Error at MB: 100
[mpeg4 @ 0x12d84a0] concealing 920 DC, 920 AC, 920 MV errors
[mpeg4 @ 0x12d84a0] 2. marker bit missing in 3. esc
[mpeg4 @ 0x12d84a0] Error at MB: 401
[mpeg4 @ 0x12d84a0] concealing 617 DC, 617 AC, 617 MV errors
[mpeg4 @ 0x12d84a0] ac-tex damaged at 14 2
[mpeg4 @ 0x12d84a0] Error at MB: 96
[mpeg4 @ 0x12d84a0] concealing 920 DC, 920 AC, 920 MV errors
[mpeg4 @ 0x12d84a0] ac-tex damaged at 5 5
[mpeg4 @ 0x12d84a0] Error at MB: 210
[mpeg4 @ 0x12d84a0] concealing 920 DC, 920 AC, 920 MV errors
[mpeg4 @ 0x12d84a0] ac-tex damaged at 24 6
[mpeg4 @ 0x12d84a0] Error at MB: 270
[mpeg4 @ 0x12d84a0] concealing 820 DC, 820 AC, 820 MV errors
[mpeg4 @ 0x12d84a0] ac-tex damaged at 0 6
[mpeg4 @ 0x12d84a0] Error at MB: 246
[mpeg4 @ 0x12d84a0] concealing 920 DC, 920 AC, 920 MV errors
[mpeg4 @ 0x12d84a0] ac-tex damaged at 31 2
[mpeg4 @ 0x12d84a0] Error at MB: 113
[mpeg4 @ 0x12d84a0] concealing 920 DC, 920 AC, 920 MV errors
[mpeg4 @ 0x12d84a0] ac-tex damaged at 15 3
[mpeg4 @ 0x12d84a0] Error at MB: 138
[mpeg4 @ 0x12d84a0] concealing 920 DC, 920 AC, 920 MV errors
[mpeg4 @ 0x12d84a0] I cbpy damaged at 22 6
[mpeg4 @ 0x12d84a0] Error at MB: 268
[mpeg4 @ 0x12d84a0] concealing 920 DC, 920 AC, 920 MV errors
[mpeg4 @ 0x12d84a0] ac-tex damaged at 1 6
[mpeg4 @ 0x12d84a0] Error at MB: 247
[mpeg4 @ 0x12d84a0] concealing 774 DC, 774 AC, 774 MV errors
[mpeg4 @ 0x12d84a0] ac-tex damaged at 12 2
[mpeg4 @ 0x12d84a0] Error at MB: 94
[mpeg4 @ 0x12d84a0] concealing 920 DC, 920 AC, 920 MV errors
[mpeg4 @ 0x12d84a0] ac-tex damaged at 16 2
[mpeg4 @ 0x12d84a0] Error at MB: 98
[mpeg4 @ 0x12d84a0] concealing 920 DC, 920 AC, 920 MV errors
[mpeg4 @ 0x12d84a0] 1. marker bit missing in 3. esc
[mpeg4 @ 0x12d84a0] Error at MB: 131
[mpeg4 @ 0x12d84a0] concealing 920 DC, 920 AC, 920 MV errors
[mpeg4 @ 0x12d84a0] ac-tex damaged at 30 2
[mpeg4 @ 0x12d84a0] Error at MB: 112
[mpeg4 @ 0x12d84a0] concealing 920 DC, 920 AC, 920 MV errors
[mpeg4 @ 0x12d84a0] Error at MB: 71
[mpeg4 @ 0x12d84a0] concealing 920 DC, 920 AC, 920 MV errors
[mpeg4 @ 0x12d84a0] ac-tex damaged at 15 3
[mpeg4 @ 0x12d84a0] Error at MB: 138
[mpeg4 @ 0x12d84a0] concealing 920 DC, 920 AC, 920 MV errors
[mpeg4 @ 0x12d84a0] ac-tex damaged at 23 2
[mpeg4 @ 0x12d84a0] Error at MB: 105
[mpeg4 @ 0x12d84a0] concealing 920 DC, 920 AC, 920 MV errors
[mpeg4 @ 0x12d84a0] 2. marker bit missing in 3. esc
[mpeg4 @ 0x12d84a0] Error at MB: 262
[mpeg4 @ 0x12d84a0] concealing 825 DC, 825 AC, 825 MV errors
frame=  197 fps=  0 q=31.0 Lsize=     473kB time=00:00:15.00 bitrate= 258.1kbits/s dup=0 drop=1
video:458kB audio:0kB global headers:0kB muxing overhead 3.164174%

Attachments (1)

getting_stuck.avi (1.2 MB) - added by cehoyos 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by cehoyos

comment:1 Changed 5 years ago by cehoyos

  • Keywords regression added
  • Priority changed from normal to important
  • Status changed from new to open

There are still some artefacts visible (but no more error messages), and this is a regression compared to 0.5.

comment:2 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avcodec
  • Reproduced by developer set

The visible artefacts (tearing) are a regression since a0cd98b5943a7807aff837f9adba1dd034ec2272 (therefore related to ticket #127), the file was unplayable before since r20997, older revisions worked fine.

comment:3 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Fixed in current git head.

comment:4 Changed 5 years ago by cehoyos

  • Keywords asp added
Note: See TracTickets for help on using tickets.