Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#364 closed defect (fixed)

Workaround for RV40 timestamps

Reported by: roytam1 Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: real timestamp
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no


The timestamps in RV40 stream (especially B-frames) is messy which need to be workarounded for a smooth playback.

Attachments (1)

rmdec.diff (13.8 KB) - added by roytam1 5 years ago.
rm timestamp workaround patch for libavformat

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by roytam1

rm timestamp workaround patch for libavformat

comment:1 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from new to closed

The timestamps have been fixed by Kostya.

The patch you posted was written (possibly among others) by Balatoni Denes, Arpi and Michael and was published under the GPL (not the LGPL). I assume you did not know the patch could not be applied to FFmpeg due to these license issues, but you should have explained that you did not write the patch yourself and instead told us where you found it.

comment:2 Changed 4 years ago by cehoyos

  • Keywords real added; rm rmvb removed
Note: See TracTickets for help on using tickets.