Opened 5 years ago

Closed 5 years ago

#3613 closed defect (fixed)

transcode_aac test fails to build

Reported by: brad Owned by: Timothy_Gu
Priority: normal Component: documentation
Version: git-master Keywords: examples
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description (last modified by Timothy_Gu)

Updating to the FFmpeg 2.2 branch I noticed one of the tests (transcode_aac) fails to build.

doc/examples/transcode_aac.c:56: error: type qualifiers ignored on function return type

Change History (8)

comment:1 Changed 5 years ago by Timothy_Gu

  • Component changed from undetermined to documentation

Code:

static char *const get_error_text(const int error) { ... }

It should be static const char *get_error_text.

comment:2 Changed 5 years ago by brad

And that does build.

comment:3 Changed 5 years ago by brad

Please commit the fix as mentioned by Timothy.

comment:4 Changed 5 years ago by Timothy_Gu

  • Description modified (diff)
  • Owner set to Timothy_Gu
  • Status changed from new to open

I will send a patch in ~2 days (because I forgot about this ticket). Anyway thanks for the confirmation.

comment:5 Changed 5 years ago by brad

ping.

comment:6 Changed 5 years ago by Timothy_Gu

Sorry for the delay. Patch sent.

comment:7 Changed 5 years ago by Timothy_Gu

  • Keywords examples added
  • Reproduced by developer set
  • Version changed from 2.2.1 to git-master

comment:8 Changed 5 years ago by Timothy_Gu

  • Resolution set to fixed
  • Status changed from open to closed

Fixed in http://git.videolan.org/?p=ffmpeg.git;a=commit;h=9f02a2b2240028de6bf48659170ea697f393a2ee. 2.3.2 and 2.2.7 will receive this bug fix (2.2.6 was just released 5 hours ago, sorry the patch didn't make it.)

Note: See TracTickets for help on using tickets.