Opened 5 years ago

Closed 5 years ago

#3609 closed defect (duplicate)

ffplay can not playback some mmsh url

Reported by: chinshou Owned by:
Priority: normal Component: avformat
Version: unspecified Keywords:
Cc: nfxjfg@googlemail.com Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
ffplay can not playback some mmsh url

How to reproduce:

% ffplay -v 999 http://simul.freebit.net:8310/fmsenri
ffplay version N-62460-gef818d8 Copyright (c) 2003-2014 the FFmpeg developers
  built on Apr 14 2014 22:01:48 with gcc 4.8.2 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-av
isynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab
le-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetyp
e --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --ena
ble-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-l
ibopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libsp
eex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-aa
cenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavp
ack --enable-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable
-zlib
  libavutil      52. 76.100 / 52. 76.100
  libavcodec     55. 58.103 / 55. 58.103
  libavformat    55. 37.100 / 55. 37.100
  libavdevice    55. 13.100 / 55. 13.100
  libavfilter     4.  4.100 /  4.  4.100
  libswscale      2.  6.100 /  2.  6.100
  libswresample   0. 18.100 /  0. 18.100
  libpostproc    52.  3.100 / 52.  3.100
[http @ 03fe2b20] request: GET /fmsenri HTTP/1.1B sq=    0B f=0/0
User-Agent: Lavf/55.37.100
Accept: */*
Range: bytes=0-
Connection: close
Host: simul.freebit.net:8310


[http @ 03fe2b20] header='HTTP/1.1 200 OK'    0KB sq=    0B f=0/0
[http @ 03fe2b20] http_code=200
[http @ 03fe2b20] header='Content-Type: video/x-ms-asf'
[http @ 03fe2b20] header='Cache-Control: max-age=0, no-cache'
[http @ 03fe2b20] header='Server: Cougar/9.01.01.3863'
[http @ 03fe2b20] header='Content-Length: 124'
[http @ 03fe2b20] header='Date: Sun, 04 May 2014 14:56:44 GMT'
[http @ 03fe2b20] header='Pragma: no-cache, xResetStrm=1'
[http @ 03fe2b20] header='Supported: com.microsoft.wm.srvppair, com.microsoft.wm
.sswitch, com.microsoft.wm.predstrm, com.microsoft.wm.fastcache, com.microsoft.w
m.startupprofile'
[http @ 03fe2b20] header='Connection: close'
[http @ 03fe2b20] header=''
[AVIOContext @ 03fe3640] Statistics: 124 bytes read, 0 seeks
http://simul.freebit.net:8310/fmsenri: Invalid data found when processing input

ffmpeg can not playback the url(http://simul.freebit.net:8310/fmsenri) correctly. vlc player can correctly detect it as a mmsh stream and playback it correctly.

best regards

Change History (3)

comment:1 Changed 5 years ago by gjdfgh

It works if you replace the http:// prefix with mmsh://, but yeah it would be nice if it worked out of the box.

comment:2 Changed 5 years ago by gjdfgh

  • Cc nfxjfg@googlemail.com added

comment:3 Changed 5 years ago by cehoyos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of ticket #2001.

Note: See TracTickets for help on using tickets.